MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Display sendet "Kein Signal" anstatt sich auszuschalten



  • Hallo zusammen,
    seit einigen Tagen stehe ich vor einem Problem mit meinem Display. Die MagicMirror Module laufen, der Bewegungsmelder steuert den HDMI Eingang und kann diesen an- und ausschalten. Jedoch sendet das Controller Board “Kein Signal” und die Hintergrundbeleuchtung bleibt an. Meine Vorstellung ist, dass sich das Display komplett ausschaltet. Jedoch habe ich hier noch keine Lösung gefunden!

    Folgende HW ist verbaut:

    Display: LG LP 173WF1 B3

    Controller: TV/HDMI/VGA/AV/USB/Audio LCD Control Board für b156hw01 lp173wf1 1920x1080 LCD

    Erfolglos versuche ich gerade mit dem cec utils eine Lösung zu finden. Jedoch mit dem Befehl: echo standby 0 | cec-client -s -d 1 erhalte ich nur die Meldung, dass eine Verbindung zum CEC Adapter hergestellt wird. Das Display bleibt an.

    Versucht habe ich erfolglos:
    vcgencmd display_power 0 und
    vcgencmd display_power 1

    sowie
    tvservice --off
    tvservice --on

    Alles ohne Erfolg, das Display sendet “Kein Signal” und bleibt an.

    Gibt es eine Möglichkeit, dass Display über einen anderen Weg auszuschalten? Mit der Fernbedienung schalte ich das Controller Board komplett aus, hierbei wird aber auch der Raspberry stromlos, da dieser am USB Port des Controllers angeschlossen ist.
    Ich hoffe meine Erklärungen reichen für eine Lösung aus.

    Danke


  • Module Developer

    see english text below
    Ich hatte ein ähnliches Problem mit meinem LG Monitor, die Lösung ist zwar nicht schön aber funktioniert.
    Der Monitor verhält sich bei Grafiksignaltrennung unter VGA anders als unter HDMI, so habe ich mir einen HDMI->VGA Adapter am Pi angeschlossen und den Monitor mit VGA verkabelt, so geht es wie es soll (kein Signal Meldung nur für wenige Sekunden).

    Keine Angst bei VGA, VGA kann auch FullHD Auflösung.

    Gruß

    AxLED


    I had a similar problem with my LG monitor, the solution is not nice but works.
    The monitor behaves differently in graphic signal shutdown under VGA than under HDMI, so I have an HDMI-> VGA adapter at the Pi connected and wired the monitor with VGA, it works as it should (no signal message only for a few seconds).

    Do not worry at VGA, VGA can also use FullHD resolution.

    Regards

    AxLED



  • Das werde ich morgen Abend versuchen und gebe ein Feedback. Danke



  • Ich habe am Pi nun einen HDMI–>VGA Adapter angeschlossen. Das Ergebnis bleibt dasselbe. Nach einiger Zeit schaltet sich nicht nur das Display aus, sondern direkt das ganze Board, welches ich dann nur noch über die Fernbedienung starten kann.
    Ich nutze die gleichen Befehle und in der /boot/config.txt habe ich nichts geändert…

    Ein Test mit einem anderen Monitor ist erfolgreich, er schaltet aus und wieder ein (mit HDMI–>VGA Adapter), wie ich es mit dem PIR Sensor vorhatte. Aufgrund der Bauweise des Displays kann ich dieses aber nicht verwenden.

    Es scheint, so als ob ich mich von dem Display und dem Board trennen müsste. Kennt jemand eine passende Kombination oder hat eine Empfehlung für ca. 100 Euro?

    Danke



  • @canberra Can you tell us what controller board exactly you have? You mentioned a remote. Is it correct to assume you a universal controller board like the V56 boards? If so, you’ll need an extra relay to power on/off the display. Although it should power off normally once there’s no HDMI signal anymore. @cruunnerr wrote a very detailed guide on how to use a PIR sensor with your mirror. It offers lots of possible pathways and they are very well explained. Have a look.

    Offtopic: Even with a broken English you might get better help than asking in German only.



  • Okay, i hope it isn’t to late. From now i’m going to write in english.

    Yes, the Controller is a V56.
    Here is the ID: R17112253-GA00668
    M215H1-L03 (1920x1080) V56.

    I also found a hint to switch the display with an extra relay. When it is the only way, then it has to be…
    I hoped there would be an easier way.

    I will check the guide of @cruunnerr.

    Thanks a lot!!



  • @canberra The display should at least power off once there’s no HDMI signal detected anymore. It’s a bit weird it doesn’t do it in your case. However, it wouldn’t power back on after the HDMI port has been activated again. Therefore you’ll need a relay for sure.
    It’s working really great in my case. I’ve got the PIR-sensor and the relays from AliExpress for just a couple of cents. You can also try those 12V PIR-Sensors, that you plug in between the power supply and your LCD controller board. It’s not working in my case, though. Looks like some signal noise keeps it awake all the time.



  • Thanks.
    The Pir is also working fine in my case.
    I’m going to buy a relay and then i will see.

    Kind regards



  • Konnte das Problem mittlerweile gelöst werden?

    Ich habe nämlich das gleiche Problem und überlege auf ein anderes Board umzusteigen ein VGA Board von Pollin evtl. kann dies das Problem lösen.

    LG



  • If it is still in progress. Use this board:

    https://www.pollin.de/p/lvds-interface-pi-mt6820-vga-zu-lvds-810220

    5€and it is working perfect!

    Best,

    MaxxMagic


Log in to reply