MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

MM Error - .AppleDouble and UnhandledPromiseRejectionWarning



  • Hi guys,

    I’m experiencing an issue with MM.

    Each time I quit MM, I can see those errors in the terminal (after the “launching application line”:

    Launching application.
    ERROR! Could not find main module js file for .AppleDouble
    (node:365) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): TypeError: Cannot read property 'refs' of undefined
    (node:365) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
    (node:365) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 2): TypeError: Cannot read property 'refs' of undefined
    (node:365) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 3): TypeError: Cannot read property 'refs' of undefined
    
    

    The .AppleDouble thing is always here…
    The (node: XXXX) is always here but the XXXX is different each time.

    Does anyone knows what it is related to and how we could fix that?
    (I even don’t know how to start an analysis, etc…)

    Thanks already for your help.



  • I’ve searched the forum again and ZERO mention to .appledouble issue…
    No one experienced that?


  • Project Sponsor Module Developer

    @bolish said in MM Error - .AppleDouble and UnhandledPromiseRejectionWarning:

    .appledouble issue…

    This seems to be specific to the MacOS. If you google “.appledouble issue…” you’ll find some interesting reads


  • Project Sponsor

    @bolish
    Regarding the UnhandledPromiseRejection, you’d have to find out which module is creating this.
    Can you list the modules you are using?
    I had this error with MMM-rfacts. Do you have that installed?


  • Project Sponsor

    @bolish I would guess your system has created an .appledouble file in the modules directory.
    wikipedia says the file is created for so-called double-forks used in the A/UX system.

    Don’t know if there’s a wa to ignore files/folders in the modules directory.



  • You will have had your files on the OS X computer, then OS X automatically makes these .AppleDouble files.
    Search your Magic Mirror completely for these files and delete them.
    These can be safely deleted.



  • @Mykle1 @lavolp3 @robiv8
    .appledouble : found the rootcause!!
    I believe it’s because I mounted my raspberry Pi as a share on my MacBook.
    By making “all hidden files visible” on the Pi, I noticed that ALL (literally ALL) folders on the Pi where showing an .appledouble folder with a lot of files inside…
    By removing the .appledouble folder which was into the /MagicMirror/Modules one…this error message stopped.
    I’m convinced this .appledouble folder will be created again later my the MacOs…Nevertheless, I’m now sure that this error message was not causing any trouble in the end…So everything fine.

    Anyway, thanks for support!!



  • @lavolp3

    Here is the list of the modules I’m using :

    0_1550178968289_Screenshot_ 20190214_ 221537.png

    It’s a lot…So it seems difficult to identify the one causing the issue, don’t you think so? Maybe you know an analysis method that could help?

    Do you think that by “disabled : true” then one by one, it could work to identify which one is causing the issue?

    Regards


  • Project Sponsor

    @bolish Well at first I would rule out:

    MMM-Wunderlist
    MMM-remote-control
    MMM-SystemStats
    calendar_monthly
    all in default

    I have these as well and not the message you’re finding.
    What you could try out:
    There is a module MMM-Logging by @shbatm giving the logging output more detail. It’s easy to install and you don’t need to configure anything.
    That module could be able to show where the unhandled promise reection is sitting.



  • @lavolp3
    OK I will give it a try this weekend and check the logs.
    Disabling them on by one (through the config.js) will not help?