MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

error when try to start mm

  • npm info it worked if it ends with ok
    npm info using npm@5.0.3
    npm info using node@v8.1.3
    npm info lifecycle magicmirror@2.6.0~prestart: magicmirror@2.6.0
    npm info lifecycle magicmirror@2.6.0~start: magicmirror@2.6.0

    magicmirror@2.6.0 start /opt/magic_mirror

    npm info lifecycle magicmirror@2.6.0~start: Failed to exec start script
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! magicmirror@2.6.0 start: sh
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the magicmirror@2.6.0 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /fakehome/root/.npm/_logs/2019-02-10T00_24_58_360Z-debug.log

  • I figured out the error occured when I try to run mm from ssh if I run directly on rpi consol it works?

    But I need to find solution to run mm from ssh. How?

  • Module Developer

    Have you read the readme of MagicMirror?

    Also note that:

    npm start does not work via SSH. But you can use DISPLAY=:0 nohup npm start & instead.
    This starts the mirror on the remote display.


Log in to reply