MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Infrared Touch Frame - rotate?

  • Hi there! I have my MagicMirror up and running in portrait mode and works well. I have just added a 42" Infrared Touch Frame Overlay but the touch cursor moves the wrong direction (ie. the touch cursor stuck to landscape)
    How does one calibrate the touch cursor to portrait mode? I slide my finger up the mirror and the cursor moves right ~ lol.

    I have installed xinput but not sure how or where to adjust the settings.

    Any help appreciated!

  • Moderator

    Did you install xinput_calibrator?

  • @yawns Hello, yes and just finished running the xinput touch calibrator program under preferences (it had me touch the 4 red crosses). No issues there but I don’t know how or where to change the touch programming to “portrait” mode. I slide my finger up the monitor and the curser moves left.
    Would you have any instructions? Thanks again!

  • @sdetweil Awesome thanks!

    In his website link I created the file but don’t wuite understand this 2nd part in his instructions:
    “Afterwards, I also made launchers to automatically run each shell script when I tapped on them (this is possible in Xubuntu, Ubuntu MATE, and many other Ubuntu flavours). To do so, go to your panel, right-click, click on “add to panel” (or equivalent, for all these subsequent commands, too), create a custom application launcher. For portrait’s launcher, put in this command:

    sh /home/username/Scripts/portrait”

    Are you able to elaborate? I am somewhat new to this 🙂
    Appreciate the guidance!
    ~ Eric.

  • @peemoeller he made apps(launcher) in the ubuntu graphical interface. So he could switch orientations just from a menu.

    If u are doing just once, u won’t need that.

    But he may have left out a step.
    From the command shell, where your little script is located, do

    chmod +x

    To make the script executable

  • @sdetweil That worked! Nice 🙂
    In Terminal I entered: chmod +x
    Then executed the file I made
    and the touch IR is now set to portrait.

    So happy, thanks for your help buddy!

    I’ve re-ran the “Calibrate Touchscreen” in Preferences again too. It reads:

    < Calibrating standard Xorg driver “Multi touch overlay device” current calibration values: min_x=0, max_x=65535 and min_y=0, max_y=65535
    If these values are estimating wrong, either supply it manually with the - -precalib option, or run the ‘’ script to automatically get it (through HAL). >

    I find the touch curser doesn’t reach the the edges of my monitor. Example I can’t simply click on the Raspberry Icon in the corner. The curser is diaginally 2 inches away?

    Where can I set or adjust this? Any thoughts?


Log in to reply