Black screen after Update again



  • Hey Guys.
    After the Update i got a black screen and it seems not to be the PIR. With the Remote Module i see everything in the Browser, but the screen shows nothing.
    This is the LOG

    /home/pi/.pm2/logs/mm-error.log last 15 lines:
    0|mm       |     at IncomingMessage.emit (events.js:187:15)
    0|mm       |     at endReadableNT (_stream_readable.js:1090:12)
    0|mm       |     at process._tickCallback (internal/process/next_tick.js:63:19)
    0|mm       | npm ERR! code ELIFECYCLE
    0|mm       | npm ERR! errno 1
    0|mm       | npm ERR! magicmirror@2.7.1 start: `sh run-start.sh`
    0|mm       | npm ERR! Exit status 1
    0|mm       | npm ERR!
    0|mm       | npm ERR! Failed at the magicmirror@2.7.1 start script.
    0|mm       | npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    0|mm       |
    0|mm       | npm ERR! A complete log of this run can be found in:
    0|mm       | npm ERR!     /home/pi/.npm/_logs/2019-04-06T11_59_36_840Z-debug.log
    0|mm       | XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e g happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
    0|mm       | ATTENTION: default value of option force_s3tc_enable overridden by environment.
    
    

    the complete Log:
    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/bin/node’, ‘/usr/bin/npm’, ‘start’ ]
    2 info using npm@6.8.0
    3 info using node@v9.11.2
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.7.1~prestart: magicmirror@2.7.1
    6 info lifecycle magicmirror@2.7.1~start: magicmirror@2.7.1
    7 verbose lifecycle magicmirror@2.7.1~start: unsafe-perm in lifecycle true
    8 verbose lifecycle magicmirror@2.7.1~start: PATH: /usr/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/$
    9 verbose lifecycle magicmirror@2.7.1~start: CWD: /home/pi/MagicMirror
    10 silly lifecycle magicmirror@2.7.1~start: Args: [ ‘-c’, ‘sh run-start.sh’ ]
    11 silly lifecycle magicmirror@2.7.1~start: Returned: code: 1 signal: null
    12 info lifecycle magicmirror@2.7.1~start: Failed to exec start script
    13 verbose stack Error: magicmirror@2.7.1 start: sh run-start.sh
    13 verbose stack Exit status 1
    13 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:301:16)
    13 verbose stack at EventEmitter.emit (events.js:180:13)
    13 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    13 verbose stack at ChildProcess.emit (events.js:180:13)
    13 verbose stack at maybeClose (internal/child_process.js:936:16)
    13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)
    14 verbose pkgid magicmirror@2.7.1
    15 verbose cwd /home/pi/MagicMirror
    16 verbose Linux 4.14.79-v7+
    17 verbose argv “/usr/bin/node” “/usr/bin/npm” “start”
    18 verbose node v9.11.2
    19 verbose npm v6.8.0
    20 error code ELIFECYCLE
    21 error errno 1
    22 error magicmirror@2.7.1 start: sh run-start.sh
    22 error Exit status 1
    23 error Failed at the magicmirror@2.7.1 start script.
    23 error This is probably not a problem with npm. There is likely additional logging output above.
    24 verbose exit [ 1, true ]



  • after you did the git pull to get the new code,
    you did the npm install in the MM folder, right?
    and in each module folder that contains a package.json file

    the npm install loads binary files for the required additional features to make the code run.
    you need to update those to match



  • Ah ok.
    I just did it in the modul folder and for the PIR modul, not for the rest.
    Will try this later.



  • Tried it, but still the same.
    No error in the log but just the black screen.

    Dont know what i can try now. Has anybod a idea?



  • ok, open the developers window

    ctrl-shift-i
    

    and select the console tab, and scroll up to see any errors… usually red text



  • This is not possible over a terminal programm?

    The Error is back…

    0|mm       | [9898:0407/121438.093751:FATAL:bus.cc(1151)] D-Bus connection was disconnected. Aborting.
    0|mm       | XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e g happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
    0|mm       | ATTENTION: default value of option force_s3tc_enable overridden by environment.
    0|mm       | npm ERR! code ELIFECYCLE
    0|mm       | npm ERR! errno 1
    0|mm       | npm ERR! magicmirror@2.7.1 start: `sh run-start.sh`
    0|mm       | npm ERR! Exit status 1
    0|mm       | npm ERR!
    0|mm       | npm ERR! Failed at the magicmirror@2.7.1 start script.
    0|mm       | npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    0|mm       |
    0|mm       | npm ERR! A complete log of this run can be found in:
    0|mm       | npm ERR!     /home/pi/.npm/_logs/2019-04-07T10_21_07_746Z-debug.log
    0|mm       | XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e g happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
    0|mm       | ATTENTION: default value of option force_s3tc_enable overridden by environment.
    
    


  • The black screen was my fault 😞
    I did a lil mistake. After setting up a other Pi with MMM and copying my config i had the same problem. So i was checking my config (no syntax error), and everything i could rember was, that i changed this:

    var config = {
            address: "localhost",                   // Address to listen on, can be:
                                                    // - "localhost", "127.0.0.1", $
                                                    // - another specific IPv4/6 to$
                                                    // - "", "0.0.0.0", "::" to lis$
                                                    // Default, when address config$
            port: 8080,
            address: "0.0.0.0",
            ipWhitelist: [],
    

    to this:

    var config = {
            address: ["localhost", "0.0.0.0"],                  // Address to listen on, can be:
                                                    // - "localhost", "127.0.0.1", $
                                                    // - another specific IPv4/6 to$
                                                    // - "", "0.0.0.0", "::" to lis$
                                                    // Default, when address config$
            port: 8080,
            ipWhitelist: [],
    

    And that was everything and cost me a lot of time ^^


  • Project Sponsor Module Developer

    NEVER NEVER NEVER NEVER DO an update until you’ve backed everything up… THIS solves the problem if the update gets stuck or doesn’t work you just copy over your backup and you’re up and running again…



  • @cowboysdude AND backup OFF the memory card… I lost a whole bunch of stuff when we had 5 power failures back to back… 15 seconds each… memory card did not recover…

    luckily I had a ‘close’ backup… still wasted a couple days…

    now all systems on battery backup


  • Project Sponsor Module Developer

    @sdetweil said in Black screen after Update again:

    I lost a whole bunch of stuff when we had 5 power failures back to back… 15 seconds each… memory card did not recover…

    Yikes! 😞