MagicMirror² v2.11.0 is available! For more information about this release, check out this topic.
READ THE CHANGELOG BEFORE UPDATING!

MMM-EasyBack no autostart Video



  • @sdetweil

    I am trying a clean install now



  • @sdetweil

    is this the start file you are talking about?

    pi@raspberrypi:~ $ ls
    chromium_start.sh  mmstart.sh                  package-lock.json
    MagicMirror        node-v10.16.0-linux-armv6l
    pi@raspberrypi:~ $ 
    
    

    mmstart.sh?

    pi@raspberrypi:~ $ sudo nano mmstart.sh
    
      GNU nano 3.2                       mmstart.sh                                 
    
    #!/bin/bash
    cd ~/MagicMirror
    node serveronly &
    sleep 30
    xinit /home/pi/chromium_start.sh
    
    npm start dev
    

    Is that where it goes?

    Man doing this project makes me feel so dumb I need to learn more, any suggestions?



  • Oh an just to update with the clean install I had the same issue.



  • I am also now using a Raspberry Pi 3 B+



  • Well I ended up going to a static picture because I can’t think of what else to do.



  • @Darkmx-6 i don’t know where mmstart.sh came from… it is not part of the base MagicMirror solution.

    the MagicMirror start script is ~/MagicMirror/installers/mm.sh

    it does not run serveronly… it assumes you are running the mirror user experience ON the same machine.

    i don’t know if EasyBack works on the remote client of serveronly… THAT browser would have to enable autoplay… our fix was for the electron browser running ON the same machine

    edit:
    ok, i see what you are doing… using chromium for the browser for some reason…

    so u have to disable the autoplay blocker there , from
    https://developers.google.com/web/updates/2017/09/autoplay-policy-changes

    You can decide to disable entirely the autoplay policy by setting the 
    Chrome flag "Autoplay Policy" to "No user gesture is required" at chrome://flags/#autoplay-policy. 
    This allows you to test your website as if user were strongly engaged with your site and playback autoplay would be always allowed.
    


  • Ah I see! It works THANK YOU!
    Must be because of the pre-made image I installed MagicMirror with.

    Here is the link:

    http://emmanuelcontreras.com/how-to/how-to-create-a-magic-mirror-2-with-pi-zero-w/

    Here is the fix:

    I edited the file chromium_start.sh found here:

    pi@raspberrypi:~ $ ls
    chromium_start.sh  MagicMirror  mmstart.sh  node-v10.16.0-linux-armv6l  package-lock.json
    

    and added

    --autoplay-policy=no-user-gesture-required
    

    Example:

      GNU nano 3.2                          chromium_start.sh                                                                         
    
    #!/bin/sh
    unclutter &
    xset -dpms # disable DPMS (Energy Star) features.
    xset s off # disable screen saver
    xset s noblank # don’t blank the video device
    matchbox-window-manager &
    #midori -e Fullscreen -a http://localhost:8080
    chromium-browser --autoplay-policy=no-user-gesture-required --incognito --kiosk http://localhost:8080/
    


  • @Darkmx-6 cool!.. great feedback, thanks we missed that this was a pi0, and that you were running split mode…



  • @sdetweil said in MMM-EasyBack no autostart Video:

    is was a pi0, and that you were running split mode…

    what is split mode? If I am I didn’t mean to, I have it directly connected to a TV that I am using as a Bulletin board.



  • @Darkmx-6 there are two ways to run Magic Mirror

    all in one(all in one application) , uses electron, npm start.
    we’ve solved the pi 0 problem… my installer handles it

    split mode (two applications)
    start serverOnly
    then view with some other browser (chrome, firefox, ie, …) either locally or from another machine/phone…