MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM_MotionEye Error because its MIME type ('text/html') is not executable



  • I get the following error message when starting MM2

    “Refused to execute script from ‘http://localhost:8080/modules/MMM_MotionEye//MMM_MotionEye.js’ because its MIME type (‘text/html’) is not executable, and strict MIME type checking is enabled.”, source: http://localhost:8080/ (0)

    All other modules start Ok

    Running On Raspberry PI2, Raspbian GNU/Linux 9 (stretch)

    Any idea how to correct this?


  • Project Sponsor

    @dssdss - Please post your relevant portion of the config.js. Right now, it looks like you have an extra slash in your path to your module. (the “MMM_MotionEye//MMM_MotionEye.js” part of the error). At a guess, I would say that your configuration file says something like module: "MMM_MotionEye/", but I would want to look at it to be sure.

    Other questions: Has this module worked before for you? Did you see any errors during install?



  • 1st time I have installed the module.
    I have deleted and reconfigured it also 2 times with the same result.
    I also tried using Firefox-esr instead of Chromium and get the same error
    This is the 1st time I am using MagicMirror2. I cloned the repository last week and default Modules work.
    I also am using module MMM-Sort and it works ok
    I also tried a couple of other modules and I got the same error.
    From the research I have done most of it points to the webserver config but that is beyond me. Do you know the location of the webserver config file is and I can try testing that with some of the info I found in my searches.

    {
    module: ‘MMM-MotionEye’,
    position: ‘bottom_right’,
    config: {
    url: “http://192.168.254.109:8081”,
    forcedRefreshInterval: 60000,
    width: 400px,
    debug: false
    }
    },

    thx



  • Thx for your help, I fixed. It was my bad typing causing the error.
    With all the changes i was making to get it to work i typed “_” instead of “-”

    Thx for your help



  • See i still can’t type.

    it should read “Thx for your help, I fixed it” and not read “Thx for your help, I fixed”


  • Project Sponsor

    I’m glad you got it resolved. In the future, please post requests for help in the troubleshooting section of the forum. This area is for showing off new modules.


Log in to reply