Disappearing module



  • Hi,

    After stumbling across the Magic Mirror, I decided it was something I had to try for myself on an old Raspberry PI 2. I managed to get everything up, running and stable for several weeks, but it seems I have recently begun to have trouble with MMM-Rain-Radar - the radar screen began disappearing.

    Everything is working fine upon boot, but after 10 minutes or so the radar screen disappears - all other modules remain visible; pm2 restart brings it back for 10 minutes and again it is disappearing. Also, If I browse to the magic mirror webpage (http://xxx.xxx.xxx.xxx:8080), I see the same behavior.

    I have to admit, I have been doing a bit of tinkering with different modules, but have returned to a previously working backup of my config.js and still have the same issue. I have since upgraded my install to v2.8.0 hoping for an improvement, but no change.

    Is this possibly an issue with MMM-Rain-Radar? Has anyone encountered this or have any advice?

    Thanks!

    Henry



  • I’m suspecting this issue is due to the provider of MMM-Rain-Radar’s data. The radar image returned last night for an hour or so, before disappearing and has been working all day today. No change was made on my end.



  • Same here - feels like the source web site timing out. My mirror only displays the radar about half the time. I’ve set the refresh interval to something very low (an hour, I think) on the chance I’m being throttled.

    Any updates on this issue?


  • Project Sponsor

    please see this thread, seems related to yours

    https://forum.magicmirror.builders/topic/11661/mmm-rain-radar-module-is-suspended

    MMM-Rain-Radar might suspend itself after the 10 minutes because there’s nothing to show.

    If that’s the case, RTFM! Lol!


  • Project Sponsor Module Developer

    @lavolp3 said in Disappearing module:

    If that’s the case, RTFM! Lol!

    Hell yes! 🙂