Blank mm after update



  • @kvicksson said in Blank mm after update:

    so don’t have to bother right now?

    As long as the errors are no fatal errors that do not prevent the MagicMirror from starting or prevent a certain module from working right, you might chose to ignore them.
    But the problem is, that when you add something new or update something existing, it becomes more and more difficult to debug and/or correct in case of problems.

    When you do this:

    $ pm2 flush
    $ pm2 restart mm
    $ pm2 logs --lines 100
    

    what is the first error you see ?
    Perhaps you post the first 50 to 100 lines of the log.

    But only if you want to spend some time on it, when not that’s fine too.



  • @evroom actually no errors like I got before…

    PM2        | 2019-08-29T21:46:00: PM2 log: pid=1331 msg=failed to kill - retrying in 100ms
    PM2        | 2019-08-29T21:46:00: PM2 log: App [mm:0] exited with code [0] via signal [SIGINT]
    PM2        | 2019-08-29T21:46:00: PM2 log: pid=1331 msg=process killed
    PM2        | 2019-08-29T21:46:00: PM2 log: App [mm:0] starting in -fork mode-
    PM2        | 2019-08-29T21:46:00: PM2 log: App [mm:0] online
    
    /home/pi/.pm2/logs/mm-out.log last 100 lines:
    0|mm       | Shutting down server...
    0|mm       | Stopping module helper: updatenotification
    0|mm       | Stopping module helper: mmm-systemtemperature
    0|mm       |
    0|mm       | > magicmirror@2.8.0 start /home/pi/MagicMirror
    0|mm       | > sh run-start.sh
    0|mm       |
    0|mm       | Starting MagicMirror: v2.8.0
    0|mm       | Loading config ...
    0|mm       | Loading module helpers ...
    0|mm       | No helper found for module: alert.
    0|mm       | Initializing new module helper ...
    0|mm       | Module helper loaded: updatenotification
    0|mm       | Initializing new module helper ...
    0|mm       | Module helper loaded: mmm-systemtemperature
    0|mm       | No helper found for module: clock.
    0|mm       | Initializing new module helper ...
    0|mm       | Module helper loaded: calendar
    0|mm       | Initializing new module helper ...
    0|mm       | Module helper loaded: MMM-YrThen
    0|mm       | Initializing new module helper ...
    0|mm       | Module helper loaded: mmm-weatherchart
    0|mm       | Initializing new module helper ...
    0|mm       | Module helper loaded: newsfeed
    0|mm       | All module helpers loaded.
    0|mm       | Starting server on port 8080 ...
    0|mm       | Server started ...
    0|mm       | Connecting socket for: updatenotification
    0|mm       | Connecting socket for: mmm-systemtemperature
    0|mm       | Starting node helper: mmm-systemtemperature
    0|mm       | Connecting socket for: calendar
    0|mm       | Starting node helper for: calendar
    0|mm       | Connecting socket for: MMM-YrThen
    0|mm       | MMM-YrThen 8/29/2019 9:46:08 PM: Starting helper for MMM-YrThen
    0|mm       | Connecting socket for: mmm-weatherchart
    0|mm       | Starting node helper: mmm-weatherchart
    0|mm       | Connecting socket for: newsfeed
    0|mm       | Starting module: newsfeed
    0|mm       | Sockets connected & modules started ...
    0|mm       | Launching application.
    
    /home/pi/.pm2/logs/mm-error.log last 100 lines:
    0|mm       | /home/pi/MagicMirror/node_modules/electron/dist/electron: /lib/arm-linux-gnueabihf/libdbus-1.so.3: no version information available (required by /home/pi/MagicMirror/node_modules/electron/dist/electron)
    0|mm       | /home/pi/MagicMirror/node_modules/electron/dist/electron: /lib/arm-linux-gnueabihf/libdbus-1.so.3: no version information available (required by /home/pi/MagicMirror/node_modules/electron/dist/electron)
    0|mm       | (node:2465) [DEP0025] DeprecationWarning: sys is deprecated. Use util instead.
    0|mm       | /proc/self/exe: /lib/arm-linux-gnueabihf/libdbus-1.so.3: no version information available (required by /proc/self/exe)
    0|mm       | ATTENTION: default value of option force_s3tc_enable overridden by environment.
    

    I really appreciate you want to look into my errors, I’m not too good on this 🙂



  • @kvicksson

    Doesn’t look too bad.
    Probably you saw the previous errors in your log output, that it is why flushing (pm2 flush) sometimes cannot hurt.

    In order to know a bit about your environment, can you post the output of the following commands ?
    I am assuming you are using a Raspberry Pi

    $ cat /proc/device-tree/model
    $ lsb_release -a
    $ npm --version
    $ node --version
    $ pm2 --version
    $ cat /boot/config.txt | egrep -v '^$|^#|^['
    

    I also would suggest to see if npm shows any errors:

    $ cd ~/MagicMirror
    $ npm audit
    

    In my case a

    $ npm audit fix
    

    solved the dependency issues it found.

    Perhaps others have different ideas, but as a hobbyist, I would take these steps first myself.


  • Project Sponsor

    @evroom said in Blank mm after update:

    In my case a
    $ npm audit fix

    solved the dependency issues it found.

    The npm audit warnings do not create any problems in running the mirror as far as I know. They also do not show up in the pm2 logs.
    I would even be very careful as an inexperienced user to do that. “Fixing” these npm warnings on the root MM install could break the whole mirror (not the mirror itself of course :-)). Especially if you mess with the electron/chromium dependencies.



  • @evroom got an error on the egrep command:

    pi@raspberrypi:~ $ cat /proc/device-tree/model
    Raspberry Pi 3 Model B Rev 1.2pi@raspberrypi:~ $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Raspbian
    Description:    Raspbian GNU/Linux 8.0 (jessie)
    Release:        8.0
    Codename:       jessie
    pi@raspberrypi:~ $ npm --version
    5.6.0
    pi@raspberrypi:~ $ node --version
    v9.11.2
    pi@raspberrypi:~ $ pm2 --version
    3.5.1
    pi@raspberrypi:~ $ cat /boot/config.txt | egrep -v '^$|^#|^['
    grep: Invalid regular expression
    


  • @kvicksson said in Blank mm after update:

    got an error on the egrep command

    Forgot to escape the [, try this:

    cat /boot/config.txt | egrep -v '^$|^#|^['
    

    EDIT: Did not forget to escape it, it is this shitty forum that removes it.

    There needs to a backslash \ before the last [



  • @lavolp3 said in Blank mm after update:

    Fixing” these npm warnings on the root MM install could break the whole mirror

    The npm audit itself suggests to fix it using the fix option.
    I personally never had any issues with this command, but perhaps I was lucky till now.
    Sometimes it cannot resolve an issue, but it never broke anything.

    But, if it appears to be that dangerous, then indeed it is perhaps to refrain from it when not really necessary.



  • @kvicksson said in Blank mm after update:

    (node:2465) [DEP0025] DeprecationWarning: sys is deprecated. Use util instead.

    I saw this error once for a specific module.
    Needed a small code change.
    Will try to find what is was.



  • This is a command to list all your modules that are in the config.js and which ones are enabled/disabled:

    $ cat ~/MagicMirror/config/config.js | egrep 'module:|disabled' | sed -e 's/^[ \t]*//'
    


  • @evroom cool… how can u tell which module ‘disabled’ applies to?

    system 1

    module: "alert",
    disabled: false,
    module: "updatenotification",
    module: "clock",
    disabled: false,
    module: "calendar",
    disabled: false,
    module: "MMM-SleepWake",
    module: "newsfeed",
    disabled: false,
    disabled: false,
    module: 'WaterLevels',
    disabled: false,
    module: "MMM-ImagesPhotos",
    disabled: true,
    module: 'MMM-MQTTfloorplan',
    disabled: false,
    module: "MMM-AssistantMk2",
    module: "MMM-Hotword",
    disabled: false,
    disabled: true,
    module: "default/SampleModule",
    disabled: true,
    module: "MMM-GoogleMapsTraffic",
    disabled: true,
    module: "MMM-PC-Stats",
    disabled: true,
    module: 'mmm-weatherchart',
    

    system 2

    module: "alert",
    //                      module: "updatenotification",
    module: "clock",
    //                      module: "calendar",
    //                      module: 'MMM-WunderGround',
    //                      module: "newsfeed",
    disabled: false,
    module: "MMM-SleepWake",
    module: "MMM-ImagesPhotos",
    module: 'MMM-voice',
    disabled: false,
    module: 'WaterLevels',
    module: 'MMM-WatchDog',
    

    system 3

    module: "alert",
    module: "updatenotification",
    module: "clock",
    module: "calendar",
    disabled: true,
    module: "compliments",
    module: "currentweather",
    module: "weatherforecast",
    module: "newsfeed",
    module: "MMM-ImagesPhotos",
    disabled: false,
    module: "MMM-SleepWake",
    

    i wrote this little piece of node js to find active modules for my upgrade script

    const config = require('../config/config.js');const fs=require('fs');
    for(let m of config.modules){
    	if(!(m.disabled || false)){
           	console.log(m.module);
      } 
    }