MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Black screen when insert https://github.com/paphko/mmm-weatherchart



  • Hey folks,

    I have updated my whole MM-SD-Card to a new “Raspbian Buster with desktop and recommended software” and also up to MM². I got everything to work except the weatherchart of paphko (https://github.com/paphko/mmm-weatherchart). If I put the module inside config.js the MM will not come up again. the monitor stays completely black (irrelevant to mention that I tried also the default module “code” 😑 ). By the way, its possible to kill the pm2 prcoess with CTRL+Q.

    Then I tried the fork of that weatherchart-module from szech (https://github.com/szech/mmm-weatherchart). So I decided to rename the paphko-weatherchart-module-folder and to install the szech one at the correct location (/home/pi/MagicMirror/modules/mmm-weatherchart/). First I tried the default module-code and (a little success 😄 ) the MM² came up again!

    But without any weatherchart 😪 . So I decided to alter the module-config to my own settings, but nothing changed. Then I have tried some different locations for the weatherchart module, but nothing worked. The MM² shows all modules but not the desired weatherchart.

    However, one thing was noticed, as I set the same location as the newsfeed module (region = bottom_bar) the newsfeed appeared two inches higher than before 😯 . So I guess something took that space below the newsfeed. I suspect that is the szech mmm-weatherchart, but a kind of invisible.

    Thx in advance, I appreciate your help. 😊


  • Module Developer

    @prototype0815 You really need to learn how to debug/troubleshoot. There are two kinds of logs, one on the server side (in the console of your Raspberry pi) and one on the client side (in the browser).

    Open your mirror in the browser of a laptop and press F12 for dev tools. You can see on the console tab if there is an error. That’s the client side logging.

    Or go via ssh into your Raspberry pi and try dev mode. This will show you the server side logs.

    pm2 stop all
    cd ~/MagicMIrror && npm start dev
    

    But my bet is on the issue on github
    So try out this

    cd ~/MagicMirror/modules/MMM-weatherchart
    npm install del
    pm2 restart mm
    


  • Yes I do! But unfortunately I’m not very familiar with linux. I’ll give it a try. Thank you
    EDIT: npm install del doesn’t work for both modules.

    EDIT2: after the installation of “del”, the MM² come up again. But there is still no weatherchart.

    EDIT3: cd ~/MagicMIrror && npm start dev
    console issued the following text --> { [Error: EACCES: permission denied, open ‘/home/pi/MagicMirror/modules/mmm-weatherchart/cache/map-1581788960498.png’]
    errno: -13,
    code: ‘EACCES’,
    syscall: ‘open’,
    path: ‘/home/pi/MagicMirror/modules/mmm-weatherchart/cache/map-1581788960498.png’ }

    I tried ‘sudo chmod -R 777 .’ inside the mmm-weatherchart module directory. But this also dosn’t help.


  • Module Developer

    generaly caused by

    maybe:

    1. you have installed this module with root account (by using sudo ?)
    2. git clone with sudo
    3. npm install with sudo

    notes: ALL modules and MagicMirror program sould be installed with user account (pi with raspberry)
    and NOT with root account (sudo command)

    If you install with sudo command is equal to modify or rewrite a file in windows system -> you can’t access or modify it with simple windows user account



  • I installed this module yesterday and did a little debugging. The request for the graphic works ok (code=200), but the saving to disk doesn’t work for some reason.

    The web URL error also means not found. I am away from my system til late today before I can look at it again



  • ok, we have a timing problem… the file is written, but erased

    workaround

    change these lines in node_helper.js

    			http.get(options, function (response) {
    				var pngFiles = payload.mmDir + 'modules/mmm-weatherchart/cache/*.png';
    				del([pngFiles]);
    

    to

    			var pngFiles = payload.mmDir + 'modules/mmm-weatherchart/cache/*.png';
    			del.sync([pngFiles]);
    			http.get(options, function (response) {
    


  • @Bugsounet ok thank you for the explanation. I tried it with and without sudo, but it doesn’t matter. I have left the last clone of the module without the sudo command.



  • Today it was very weird, I started my MM² to reinstall the module as @Bugsounet said, and the weatherchart was visible (the first time on my MM²)! After that I decided to change the region of the weatherchart, unfortunately the weatherchart is now gone again. No region is working reliable.



  • @prototype0815 see the fix above



  • @prototype0815 see my reply above


Log in to reply