MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-AlarmClock - Sound doesn't stop



  • Hey all!

    I’m having some trouble using MMM-AlarmClock.
    The sound just doesn’t stop… plays in repeat till I close MM. (even after I turn off the alarm with touch, or the time passes…)
    Have anyone had this issue?

    I would like it to play only once, is that possible?

    {
    			module: 'MMM-AlarmClock',
    			//pages: {sec: "top_right"},
    			config: {
    				alarms: [
    					{time: "13:42", days: [0,1,2,3,4], title: "10Bis", message: "What you gonna eat today?", sound: ( "food/" + n + ".mp3"), },
    					{time: "17:50", days: [4], title: "Happy Hour!!", message: "Weekend Has Arrived,\nGo drink something ", sound: ( "drink/" + n + ".mp3")},
    					
    						],
    				popup: true,
    				touch: true,				
    				fade: true,
    				fadeTimer: 1000 * 10,
    				timer: 10000,
    				
    				
    			}
    		},
    

    Thanks!


  • Module Developer

    This post is deleted!

  • Project Sponsor Module Developer

    @doron92

    I don’t know that this is much help but I just installed and used the most basic config entry (below) and the alarm turns off as expected, based on the timer setting in the config. I changed the timer value a few times and it follows that value. Try a basic config entry (such as this one) and see if it works. At least it’s a place for you to start troubleshooting.

    {
        module: 'MMM-AlarmClock',
        position: 'top_right',
        config: {
          timer: 15 * 1000,
            alarms: [
                {time: "20:29", days: [0,1,2,3,4,5,6], title: "Soccer", message: "Get ready for soccer training!", sound: "alarm.mp3"},
            ],
        }
    },
    

Log in to reply