MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Nothing would come up on the display, the module won't run :/



  • Re: MMM-AQI
    I find this as a qonderful module but it just wont work for me, no matter what i try 😕
    Here’s what I added in my config file:

    {
    			module: 'MMM-AQI',
    			position: 'bottom_left',
    			header: 'Air Quality Index (AQI)',
    			config: {
    				token: "4xxxxxxxxxxxxxxxxxxxxxxxxxx",
    				city: "here",
    				iaqi: true,
    				updateInterval: 30 * 60 * 1000, // Every half hour.
    				initialLoadDelay: 0,
    				animationSpeed: 1000,
    				debug: false
    			}
    		},
    

    I even tried putting the name of my city, the id of my city but nothing would even show up on my mirror 😪
    Please help me!


  • Project Sponsor Module Developer

    @KaranC

    So, I recently helped another user to get this up and running. What I do remember is that the module is very particular about the city name. I think there is a url in the readme that help you attain the correct city name. This is the config entry that ultimately worked for that user

    {
              disabled: true,
    			module: 'MMM-AQI',
    			position: 'top right',
    			header: 'Air Quality Index (AQI)',
    			config: {
    				token: "your token goes here",
    				city: "Friedrichshain-Frankfurter Allee, Berlin, Germany",
    				iaqi: true,
    				updateInterval: 30 * 60 * 1000, // Every half hour.
    				initialLoadDelay: 0,
    				animationSpeed: 1000,
    				debug: false
    			}
    		},
    


  • @Mykle1
    I tried using the same lines you suggested in my config file but now with those module lines, it is asking me to create a config.js file as the current one could not be read.
    I cross checked everything like the brackets, but i guess the " disabled: t, " is coming quite far out on the left (outside the bracket line) and is causing the problem. I did try pushing it inside the bracket but the same problem persists.
    I just copied and pasted what you suggested…just added my token and tried running it with various inputs for the city to see if anything works but i got the same response everytime 😕



  • Hi @KaranC, what worked for me is typing the city in the following format

    city: "country/state/city",
    

  • Project Sponsor Module Developer

    @KaranC said in Nothing would come up on the display, the module won’t run 😕:

    " disabled: t, "

    My bad. So sorry. I create a var in my config file var t = true; to simplify things for myself.

    You would have to use disabled: true,

    Again, I apologize. That is completely my fault. I’ll fix the original post


Log in to reply