MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Mirror not displaying any modules



  • I recently installed the magic mirror repo following the instructions from the docs. I did everything and it all worked fine, until the time came to run it. I did npm run start and it showed this,

    > magicmirror@2.12.0 start /home/pi/MagicMirror
    > DISPLAY="${DISPLAY:=:0}" ./node_modules/.bin/electron js/electron.js
    
    [2020-07-05 11:02:41.744] [LOG]    Starting MagicMirror: v2.12.0
    [2020-07-05 11:02:41.812] [LOG]    Loading config ...
    [2020-07-05 11:02:41.859] [LOG]    Loading module helpers ...
    [2020-07-05 11:02:41.871] [LOG]    No helper found for module: alert.
    [2020-07-05 11:02:42.124] [LOG]    Initializing new module helper ...
    [2020-07-05 11:02:42.127] [LOG]    Module helper loaded: updatenotification
    [2020-07-05 11:02:42.131] [LOG]    No helper found for module: clock.
    [2020-07-05 11:02:44.063] [LOG]    Initializing new module helper ...
    [2020-07-05 11:02:44.065] [LOG]    Module helper loaded: calendar
    [2020-07-05 11:02:44.069] [LOG]    No helper found for module: compliments.
    [2020-07-05 11:02:44.072] [LOG]    No helper found for module: currentweather.
    [2020-07-05 11:02:44.075] [LOG]    No helper found for module: weatherforecast.
    [2020-07-05 11:02:44.203] [LOG]    Initializing new module helper ...
    [2020-07-05 11:02:44.205] [LOG]    Module helper loaded: newsfeed
    [2020-07-05 11:02:44.207] [LOG]    All module helpers loaded.
    [2020-07-05 11:02:44.772] [LOG]    Starting server on port 8080 ... 
    [2020-07-05 11:02:44.848] [LOG]    Server started ...
    [2020-07-05 11:02:44.852] [LOG]    Connecting socket for: updatenotification
    [2020-07-05 11:02:44.856] [LOG]    Connecting socket for: calendar
    [2020-07-05 11:02:44.858] [LOG]    Starting node helper for: calendar
    [2020-07-05 11:02:44.860] [LOG]    Connecting socket for: newsfeed
    [2020-07-05 11:02:44.862] [LOG]    Starting node helper for: newsfeed
    [2020-07-05 11:02:44.865] [LOG]    Sockets connected & modules started ...
    Fontconfig warning: "/etc/fonts/fonts.conf", line 100: unknown element "blank"
    [2020-07-05 11:02:45.782] [ERROR]  Whoops! There was an uncaught exception...
    [2020-07-05 11:02:45.785] [ERROR]  Error: listen EADDRINUSE: address already in use 127.0.0.1:8080
        at Server.setupListenHandle [as _listen2] (net.js:1226:14)
        at listenInCluster (net.js:1274:12)
        at GetAddrInfoReqWrap.doListen [as callback] (net.js:1413:7)
        at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:65:10) {
      code: 'EADDRINUSE',
      errno: 'EADDRINUSE',
      syscall: 'listen',
      address: '127.0.0.1',
      port: 8080
    }
    [2020-07-05 11:02:45.815] [ERROR]  MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    [2020-07-05 11:02:45.830] [ERROR]  If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    [2020-07-05 11:02:45.890] [LOG]    Launching application.
    [2020-07-05 11:03:24.978] [LOG]    Shutting down server...
    [2020-07-05 11:03:24.990] [LOG]    Stopping module helper: updatenotification
    [2020-07-05 11:03:24.993] [LOG]    Stopping module helper: calendar
    [2020-07-05 11:03:24.995] [LOG]    Stopping module helper: newsfeed
    

    I then decided to run the config check and see if I did something wrong and was hit with this error:

    > magicmirror@2.12.0 config:check /home/pi/MagicMirror
    > node js/check_config.js
    
    [2020-07-05 11:10:58.675] [INFO]   Checking file...  /home/pi/MagicMirror/config/config.js
    [2020-07-05 11:10:59.193] [LOG]    Line 1 col 1 Definition for rule 'prettier/prettier' was not found.
    /home/pi/MagicMirror/js/check_config.js:66
    			throw new Error("Wrong syntax in config file!");
    

    Here’s my config.js:

    
    /* Magic Mirror Config Sample
     *
     * By Michael Teeuw https://michaelteeuw.nl
     * MIT Licensed.
     *
     * For more information on how you can configure this file
     * See https://github.com/MichMich/MagicMirror#configuration
     *
     */
    
    var config = {
    	address: "localhost", 	// Address to listen on, can be:
    							// - "localhost", "127.0.0.1", "::1" to listen on loopback interface
    							// - another specific IPv4/6 to listen on a specific interface
    							// - "0.0.0.0", "::" to listen on any interface
    							// Default, when address config is left out or empty, is "localhost"
    	port: 8080,
    	basePath: "/", 	// The URL path where MagicMirror is hosted. If you are using a Reverse proxy
    					// you must set the sub path here. basePath must end with a /
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1"], 	// Set [] to allow all IP addresses
    															// or add a specific IPv4 of 192.168.1.5 :
    															// ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.5"],
    															// or IPv4 range of 192.168.3.0 --> 192.168.3.15 use CIDR format :
    															// ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.3.0/28"],
    
    	useHttps: false, 		// Support HTTPS or not, default "false" will use HTTP
    	httpsPrivateKey: "", 	// HTTPS private key path, only require when useHttps is true
    	httpsCertificate: "", 	// HTTPS Certificate path, only require when useHttps is true
    
    	language: "en",
    	logLevel: ["INFO", "LOG", "WARN", "ERROR"],
    	timeFormat: 24,
    	units: "metric",
    	// serverOnly:  true/false/"local" ,
    	// local for armv6l processors, default
    	//   starts serveronly and then starts chrome browser
    	// false, default for all NON-armv6l devices
    	// true, force serveronly mode, because you want to.. no UI on this device
    
    	modules: [
    		{
    			module: "alert",
    		},
    		{
    			module: "updatenotification",
    			position: "top_bar"
    		},
    		{
    			module: "clock",
    			position: "top_left"
    		},
    		{
    			module: "calendar",
    			header: "US Holidays",
    			position: "top_left",
    			config: {
    				calendars: [
    					{
    						symbol: "calendar-check",
    						url: "webcal://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics"					}
    				]
    			}
    		},
    		{
    			module: "compliments",
    			position: "lower_third"
    		},
    		{
    			module: "currentweather",
    			position: "top_right",
    			config: {
    				location: "Bangalore",
    				locationID: "1277333", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "4b32b21aaee5dd9ae4585256eed97703"
    			}
    		},
    		{
    			module: "weatherforecast",
    			position: "top_right",
    			header: "Weather Forecast",
    			config: {
    				location: "Bangalore",
    				locationID: "1277333", //ID from http://bulk.openweathermap.org/sample/city.list.json.gz; unzip the gz file and find your city
    				appid: "4b32b21aaee5dd9ae4585256eed97703"
    			}
    		},
    		{
    			module: "newsfeed",
    			position: "bottom_bar",
    			config: {
    				feeds: [
    					{
    						title: "New York Times",
    						url: "https://rss.nytimes.com/services/xml/rss/nyt/HomePage.xml"
    					}
    				],
    				showSourceTitle: true,
    				showPublishDate: true,
    				broadcastNewsFeeds: true,
    				broadcastNewsUpdates: true
    			}
    		},
    	]
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    

    I’m a complete newbie in this department and would appreciate any help you guys can offer 🙂



  • @SamBro2901 you did manual install?
    git clone and then npm install?

    is this on raspian, Linux, ?



  • @SamBro2901 looks like there were two instances running. are you using pm2 to start one instance?

    pm2 status will show you


  • Admin

    There is already something running on port 8080. A simple solution often is to just restart your Pi. 🙂



  • @sdetweil I did a manual install doing git clone and then npm install on raspbian and no, I haven’t used pm2 to run my instance, is that what I am doing wrong?
    Also, what about the error I get when running the config check?



  • @MichMich I changed the port in the config.js and it works perfectly fine now, thanks for the help and for this wonderful project 🙂



  • @SamBro2901 I’m getting this same error. What did you change the port to?



  • @ktvoort123 pick a port, add one or 10, or 100.



  • Same here.
    @MichMich this started after I updated my Raspbian to the latest, and now getting this error that I cannot resolve:

    > node js/check_config.js
    
    [2020-07-23 17:51:02.700] [INFO]   Checking file...  /home/pi/MagicMirror/config/config.js
    [2020-07-23 17:51:03.283] [LOG]    Line 1 col 1 Definition for rule 'prettier/prettier' was not found.
    /home/pi/MagicMirror/js/check_config.js:66
                            throw new Error("Wrong syntax in config file!");
                            ^
    
    Error: Wrong syntax in config file!
        at /home/pi/MagicMirror/js/check_config.js:66:10
        at FSReqWrap.readFileAfterClose [as oncomplete] (internal/fs/read_file_context.js:53:3)
    

    I’d appreciate an advise.

    Thank you.


  • Module Developer

    @Eric_H config:check hasn’t worked as of 2.12.

    Gonna have to manually run through for now.


Log in to reply