MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MMM-SpeedTest Fails to Install


  • Project Sponsor

    Hi @Bugsounet Thanks for the great module but I am having issues with installing the above module. I managed to install it fine on my Laptop running Ubuntu on Windows. When I tried to install it on my Raspberry Pi 3B+ I get an error. The error I get right at the end of the install is as follows:

    8734 silly lifecycle MMM-SpeedTest@1.0.0~postinstall: Args: [ '-c',
    8734 silly lifecycle   'echo \'Building SpeedTest module, please wait...\' && electron-rebuild 2>/dev/null >/dev/null' ]
    8735 silly lifecycle MMM-SpeedTest@1.0.0~postinstall: Returned: code: 1  signal: null
    8736 info lifecycle MMM-SpeedTest@1.0.0~postinstall: Failed to exec postinstall script
    8737 verbose stack Error: MMM-SpeedTest@1.0.0 postinstall: `echo 'Building SpeedTest module, please wait...' && electron-rebuild 2>/dev/null >/dev/null`
    8737 verbose stack Exit status 1
    8737 verbose stack     at EventEmitter. (/home/pi/.npm-global/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
    8737 verbose stack     at EventEmitter.emit (events.js:180:13)
    8737 verbose stack     at ChildProcess. (/home/pi/.npm-global/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    8737 verbose stack     at ChildProcess.emit (events.js:180:13)
    8737 verbose stack     at maybeClose (internal/child_process.js:936:16)
    8737 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)
    8738 verbose pkgid MMM-SpeedTest@1.0.0
    8739 verbose cwd /home/pi/MagicMirror/modules/MMM-SpeedTest
    8740 verbose Linux 4.14.52-v7+
    8741 verbose argv "/usr/bin/node" "/home/pi/.npm-global/bin/npm" "install"
    8742 verbose node v9.11.2
    8743 verbose npm  v6.14.8
    8744 error code ELIFECYCLE
    8745 error errno 1
    8746 error MMM-SpeedTest@1.0.0 postinstall: `echo 'Building SpeedTest module, please wait...' && electron-rebuild 2>/dev/null >/dev/null`
    8746 error Exit status 1
    8747 error Failed at the MMM-SpeedTest@1.0.0 postinstall script.
    8747 error This is probably not a problem with npm. There is likely additional logging output above.
    8748 verbose exit [ 1, true ]
    

    I tried uploading the full log but keep getting an error.



  • @mumblebaj hi, I see your log and I have see very old version of node and npm.
    Again I see an old Linux firmware. Try to update your rpi 😉


  • Project Sponsor

    @Bugsounet Thanks for the response. Will update and try again.


  • Project Sponsor

    @Bugsounet Updated and it now works fine. Thanks @Bugsounet


Log in to reply