MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

How to set ipWhitelist for all device can acess to MagicMirror v2?



  • someone help me to set that easy config


  • Moderator

    @nobita are you looking to open access to MM from all of the devices on your local network? If that’s the case you can add subnet mask of your local network.

    For example if your router gives you IP address of 192.168.1.XXX (last 3 digits aren’t important and used for example only) then you would edit ipWhitelist setting in config.js as follows:

    ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", "192.168.1.1/24"],
    

    192.168.1.1/24 is a subnet mask for all 256 IP addresses that your router can give out to devices. (this is the most common scenario and there is a chance that your setup may be different).

    Don’t forget to restart MM app after making this change.



  • @morozgrafix Thank so much for your help again


  • Module Developer

    @morozgrafix

    So sorry to revisit this problem but I can’t seem to access MM on my local network, too. I did what you suggested and edited the ipWhitelist setting in my config.js file. See below:

    var config = {
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", "192.168.1.1/24"],
    
    	language: 'en',
    	timeFormat: 12,
    	units: 'imperial',
    

    On my PC (192.168.1.4), I enter the Pi3/MM computers IP address of 192.168.1.15:8080 in a Google Chrome browser window. The browser window reports this:

    This device is not allowed to access your mirror.
    Please check your config.js or config.js.sample to change this.

    Any help would be greatly appreciated.

    Peace


  • Module Developer

    “Don’t forget to restart MM app after making this change.”

    I did restart the app, and a reboot when that didn’t work


  • Moderator

    @Mykle1 I will try to reproduce it once I get home and will get back to you. Hang tight.


  • Moderator

    @Mykle1 Sorry about delay. It looks like your RasPi is using IPv6 and earlier I gave you instructions for IPv4. Sorry about misinformation.

    For IPv6 setting ipWhitelist subnet mask to ::ffff:192.168.1.1/120 will give you access to 256 IP addresses. So your setting for ipWhitelist part in config.js would look like this:

    ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", "::ffff:192.168.1.1/120"]
    

    After making changes restart MM and try to access from browser on your computer.

    Let me know if it worked. Thanks.


  • Module Developer

    @morozgrafix - No worries about the delay at all. I appreciate your time and assistance.

    I wish I could try that right now but I have to go to work. I will try the moment I get home and let you know how I make out.
    In any case, thanks for the help.



  • Been watching this forum… Thanks guys you helped me and you didn’t even know it LOL

    I have 3 mirrors running and there was no sense trying to maintain 3 … so maintain 1 and run it off the other 2… 🙂


  • Module Developer

    @morozgrafix

    Oh yes, that worked perfectly. I couldn’t wait to get home to try it. Thank you, very much.

    If I may ask: Now that I can see MM running on the Pi3 from another computer on my network, can I merely view it or is there some control of MM that I can use remotely? If so, can you direct me to where I can find those commands? If I should ask this question elsewhere then I apologize. Kindly direct me to where I should ask, if this is the case.

    Again, thank you for your assistance and time and effort on my behalf.