MagicMirror does not work at startup



  • Hi guys,
    i followed the guide on GitHub to make it starts at startup but it does not work…
    When RaspBerry startup, appear on the screen The MagicMirror logo and it says booting up, but after that the screen disappear and the normal Debian jessie Desktop appears… how to make it work?



  • I also am having issues with auto start of the script.

    New install on raspberry pi 3 B.

    The manual start, stop and restart commands all work and when I run the pm2 save command, it does not error.

    After a reboot the mm.sh does not autostart.



  • Also having this issue. pm2 start mm.sh works. MM2 boot up screen appears on start up. But loads to desktop.



  • I am having this problem too. This is the 4th time I’ve installed MM on a RPI 3 and I don’t know what’s changed recently, but it’s not loading at boot. I followed the AutoStart wiki to the T but it won’t autostart.

    @MichMich @KirAsh4 @cowboysdude @ianperrin @yawns @Jopyth @morozgrafix - can any of you guys weigh in on this? This is kind of a big issue that it seems many folks are having.



  • I have the same issue, i did put java scrip on startup, i did look on the forum and #sebzx10r, suggest the same solution.

    https://forum.magicmirror.builders/topic/1094/pm2-mm2-not-starting-on-start-up/15

    In Raspian click Menu,Preferences,Main Menu Editor
    Click Preferences and check Default applications for LXSession
    Click OK and close main menu editor
    Now click Menu and Under Preferences click on Default applications for LXSession
    LXSession configuration opens
    Click Autostart
    Under Manual autostarted applications paste in your java command line
    click add
    close the LXSession configuration application and reboot your pi
    your java app should run after reboot
    

    Hope this help.
    Cheers,



  • @mpires did you get it working with this script?



  • I have the script working, but the only way to start mm on boot, was set

    pm2 start mm
    

    on LXSession, but yes now once i boot my Pi, mm start without any problem.



  • @mpires so in the LXSession configuration menu under ‘autostart’, simply add the line ‘pm2 start mm’ and it’ll run at boot?



  • @mpires do I need an @ in front of it?



  • You have Pm2 install?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.