DHT22 Sensor



  • Hi Experts :-)

    i’ve connected a temperature and humidity sensor DHT22 and would like to show these values.
    Is it possible to build some new module for this?

    Maybe it’s not necessary, i can readout the values via phyton script, but don’t know to integrate them…

    Greetings from Germany,
    stefanh



  • Yes, I also have this requirement.



  • https://github.com/momenso/node-dht-sensor?files=1

    Think it might be possible. Think it can Be useable.

    First hit in Google btw.

    Spit through code And learn? Or wait utill someone will have some sparetime.



  • @Wilco89

    Thank your for great googeling :-)
    I will try to integrate it myself.


  • Module Developer

    Where will I need to install node-dht-sensor using it with MagicMirror?

    a: ~/MagicMirror/ folder
    b: ~/MagicMirror/modules/ folder
    c: ~/MagicMirror/modules/MMM-Temperature/ folder

    using this command: npm install node-dht-sensor

    I would like to use it in node_helper.js inside a new module.

    Thanks!



  • @Bangee go into the directory of your new module e.g. ~/MagicMirror/modules/MMM-Temperature/ and type npm init and follow the instructions, after that type npm install --save node-dht-sensor


  • Module Developer

    @strawberry-3-141 thank you! that worked for me.
    But now i’ve got this error:

    mm-0 App threw an error during load
    mm-0 Error: Module version mismatch. Expected 49, got 48.
    mm-0     at Error (native)
    mm-0     at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:167:20)
    mm-0     at Object.Module._extensions..node (module.js:568:18)
    mm-0     at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:167:20)
    mm-0     at Module.load (module.js:458:32)
    mm-0     at tryModuleLoad (module.js:417:12)
    mm-0     at Function.Module._load (module.js:409:3)
    mm-0     at Module.require (module.js:468:17)
    mm-0     at require (internal/module.js:20:19)
    mm-0     at Object. (/home/pi/MagicMirror/modules/temperature/node_helper.js:2:17)
    mm-0 Whoops! There was an uncaught exception...
    mm-0 Error: Module version mismatch. Expected 49, got 48.
    mm-0     at Error (native)
    mm-0     at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:167:20)
    mm-0     at Object.Module._extensions..node (module.js:568:18)
    mm-0     at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:167:20)
    mm-0     at Module.load (module.js:458:32)
    mm-0     at tryModuleLoad (module.js:417:12)
    mm-0     at Function.Module._load (module.js:409:3)
    mm-0     at Module.require (module.js:468:17)
    mm-0     at require (internal/module.js:20:19)
    mm-0     at Object. (/home/pi/MagicMirror/modules/temperature/node_helper.js:2:17)
    mm-0 MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    mm-0 If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    mm-0 Launching application.
    

    On line 2:

    var sensorLib = require("node-dht-sensor");
    

    Node Version

    pi@raspberrypi:~/MagicMirror/modules $ node -v
    v6.3.1
    


  • @Bangee depending on your other post about this problem in a different thread I assume you have a newer node version installed as you had on your old sd card, so maybe this will help you https://docs.npmjs.com/cli/rebuild


  • Module Developer

    @strawberry-3-141 I’ve tried this before, but did not work for me. I’ve also made a reboot.

    Will i need to have a downgrade?



  • @Bangee never had such an issue before, did a clean install instead of copying images on sdcard, is there a reason why you copied an old image?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.