Blackscreen with no errors.



  • Hi there!
    So I have a problem that when I run sudo npm start the blank screen pops up.

    Starting MagicMirror: v2.1.2
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: updatenotification
    No helper found for module: clock.
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper ...
    Module helper loaded: newsfeed
    All module helpers loaded.
    Starting server on port 8080 ... 
    Server started ...
    Connecting socket for: updatenotification
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started ...
    Launching application.
    
    

    This is terminal log, as you can see there is no error.
    I have tried several ways to fix it like deleting modules or changing the language, Im using Kubuntu and actually wanted to try it out on my laptop before buying pi3, any idea what could cause this problem?

    Thanksies


  • Module Developer

    @zimmcognito

    You shouldn’t have to run sudo to launch the mirror. The installation guide states, “DO NOT INSTALL MagicMirror² as the root user! Always do it as the regular, non privileged pi user.”

    With that being said, is your console reporting any errors? cd into your MagicMirror directory and run npm start dev and see what you get there



  • Oh, the sudo part might be infact my bad.

    Here is the paste bin of console errors


  • Module Developer

    @zimmcognito

    You have more than a few problems going on there. Did you install your dependencies? I would try that first. Did you have the mirror running at all and it later failed when you added something? Or have you not got it to run at all?

    Personally, if installing the dependencies is not the problem, I would do a whole new installation manually, installing the latest node and npm first, then installing the dependencies, then try to running the mirror with the defaults before trying to edit anything.



  • You were totally right about administrative rights @Mykle1, I have done it from beggining and it works like a charm.


  • Module Developer

    @zimmcognito

    Oh, that’s good news. Enjoy your mirror


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.