Modules stuck at "Loading" after update...



  • Hello guys, today I updated my MagicMirror and 2 of the modules are stuck at “Loading”. What happend and how can I fix it?
    What I did was the following:
    Prior to me updating, all modules were working fine and I saw an update notification at the top of my MM, I proceded to “git pull && npm install” in $HOME/MagicMirror. After that, both of those modules (Email , and MMM-Traffic) on the bottom left are not working, they are stuck at loading. Also, why is my calendar like cut off, like the numbers are cutoff on the right.???

    Any ideas of what happened? Thanks in advance.

    alt text



  • @rodofrn Do you have anything in your logs that indicates a problem?



  • @bhepler said in Modules stuck at “Loading” after update...:

    Do you have anything in your logs that indicates a problem?

    Nope, nothing, checked multiple times (at startup, at restart, etc…). What could it be?



  • @rodofrn Other than a temporary outage of the web service? Hrm. Have you tried reinstalling those particular modules? I wonder if the new version of MM is somehow interfering with the authentication of the email and commute app.

    You should be able to replicate the commute web call with a carefully crafted CURL command. Pass it your API key and such and see if you get an error. Make sure to do so from the Pi.

    One of my mirrors had a similar issue after the update, but it sorted itself after I resolved some connectivity problems.



  • I reinstalled both ( rm -rf email and MMM-Traffic and git cloned them again) and same issue. I rechecked the logs and this is all I could find, I dont know if it has something to do with the problems:

    This 0|mm is in RED color:

    0|mm       | error: Ref refs/remotes/origin/develop is at 86ae704e8626a357e4f618a00e237bd25b6c59df but expected c492ea77f11470d96d5353cba00b3073edfc1519
    0|mm       | From https://github.com/MichMich/MagicMirror
    0|mm       |  ! c492ea7..86ae704  develop    -> origin/develop  (unable to update local ref)
    

    This 0|mm is in GREEN color:

    0|mm       | API-Call Quote reached for today -> no more calls until 0:00 PST
    0|mm       | listening for emails...
    

    EDIT: I just obtained a new API KEY for MMM-Traffic and it works now…WTH!!! What happend? let me see if i can fix email now…



  • @bhepler Email is still NOT working…any ideas? I tried multiple email accts, none work.



  • BUMP? any ideas>?



  • @rodofrn thats what the author said 3 days ago

    @ronny3050 said in Email:

    Loading for a long time indicates problem with communicating with your email service.


 

304
Online

6.0k
Users

4.5k
Topics

37.1k
Posts