MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

MagicMirror Weather



  • Good Evening,

    I looked through a couple of other posts and I am still having trouble getting the weather to display at all in the top right corner. There isn’t any message saying that my APPID isn’t valid or whatever. I followed the Complete Guide, found here: link text. Very nice job by @KirAsh4 !!

    At the end of the guide, there’s a quick note about the weather app, but I can’t seem to get it to work. I created an account at the openweathermap.org site but not sure where to go from there.

    Any advice would be much appreciated. For what it’s worth, I am very new to this type of computer magic, so a detailed instruction would be fantastic.

    Lastly, is there a way to edit the code to remove the compliments that the screen says (i.e., “You look nice!”)? I know it’s lying and I don’t want to see it.

    Thank you!!


  • Module Developer

    @Usrnme2Lng

    Paste the config entry for your weather here using this guide and I’ll take a look at it for you.

    https://forum.magicmirror.builders/topic/4247/how-to-post-code-on-the-forum-for-absolute-beginners

    It should look something like this:

    {
    		module: "currentweather",
    		position: "top_right",
    		config: {
    			location: "OPTIONAL",
    			locationID: "LOCATION ID GOES HERE",     //Location ID from http://openweathermap.org/help/city_list.txt
    			appid: "YOUR API KEY GOES HERE"             //openweathermap.org API key.
    		}
    	},
    

    There are more options you can add. See the readme file of the module, but for now lets just get you up and running



  • @Usrnme2Lng in your config.js file is a section like:

    {
        module: "compliments",
        position: "lower_third"
    },
    

    just remove that part and it will be gone



  • @Mykle1 I think I made a mistake by putting similar code in the wrong file I put it into the other config file by doing ‘sudo nano /boot/config.txt’

    How to I get to the config file you’re talking about?



  • @Usrnme2Lng said in MagicMirror Weather:

    @Mykle1 I think I made a mistake by putting similar code in the wrong file I put it into the other config file by doing ‘sudo nano /boot/config.txt’

    How to I get to the config file you’re talking about?

    I would in a terminal window go to:
    ~MagicMirror/config
    type: cp config.js.sample config.js

    That will give you your config file.

    Then you can sudo nano config.js and enter the weather info.


  • Module Developer

    OR

    My suggestion, because it helped me, is, don’t do your editing in the terminal. Do it in the graphical user interface (GUI). Navigate your desktop as you would on a PC with Windows or a Mac’s Finder.

    Click on File Manager (the folder at the top left of your desktop, usually)
    Double click the MagicMirror folder
    Double click the config folder
    Right click the config.js.sample file - select Copy
    Right click again somewhere else in that same window - select Paste
    Rename the file you just pasted to config.js and click the Rename button
    The new config.js file that you just pasted is now your working config file for MagicMirror
    Double click it and it should open in a text editor.

    This is one of the places where you will customize your MM. It’s actually good enough to run your MM, although it will only show some of the modules but you’ll be encouraged by the fact that it is at least working. Every module folder has a ReadMe file that instructs you on what to add to your config.js file to get that module up and running.



  • @strawberry-3.141 Thank you!! That worked!



  • @Mykle1 Thanks! This helped a lot. I am trying to get more comfortable with the terminal, but I think that in this case, it was best to use a text editor.

    Also, I followed the instructions in the guide but for some reason, my screen is still going blank.

    I edited the autostart file, as below:

    sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
    
    @xset s noblank
    @xset s off
    @xset -dpms
    

    I also edited the lightdm.conf file, as seen below:

    sudo nano /etc/lightdm/lightdm.conf
    

    I edited the xserver-command bit to look like this:

    xserver-command=X -s 0 -dpms
    

    Any ideas of what I can do next? For what it’s worth, it is a flatscreen TV, so it has a remote and I also tried going through the settings and made sure that sleep mode was off.



  • @Usrnme2Lng Install xscreensaver and save yourself a lot of time and headache…

    Install it on the pi then disable screensaver… easiest way to do it.

    https://www.linuxbabe.com/ubuntu/install-autostart-xscreensaver-ubuntu-16-04-16-10



  • @cowboysdude Thank you! That seems to have fixed the issue!