MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Default MagicMirror clock config timezone error



  • So I have been trying to switch the timezone in the clock.js file for the default MM clock module to New York
    I changed the timezone under analog clock to America/New_York as instructed in the module and then the clock doesn’t show up anymore
    I am using the clock in digital but I can’t find a specific timezone setting for digital
    Am I typing the timezone wrong?
    thanks,
    Adam

    If you need more information let me know



  • @Adaman134 you shouldn’t touch the clock.js file, instead do the changes in your config file

    {
    	module: "clock",
    	position: "top_left",
    	config: {
    		timezone: 'America/New_York'
    	}
    }
    

    if you are in new york you don’t have to do this at all, I would recommend to set your rpi timezone correctly instead.



  • Ok thank you, so for all the modules I should be changing it in the config.js file? So if it says I can change something like for this clock make it digital or analog I should add that line to the config.js under that module?


  • Module Developer

    @Adaman134

    Yes, every module should come with a readme file that describes the options that you can manage. All of these options should be managed in the config file entry for each module. Editing the module.js files is not recommended.



  • @Mykle1 ok thank you very much now I understand 🙂