Access MagicMirror with HTTP?



  • Hi,

    Can i access MagicMirror via http://? From internal network or from external via Port-forwarding?

    I know about VNC, but searching for a direct access just to show MagicMirrorr…



  • Hi,
    you can access Mirror in internal network using http://192.168.x.x:8080/ and use free no-ip DDNS register your raspberry pi IP with domain name and port forward in your router



  • Hi,

    Thats what I thought also…in my case, I got the following error in my browser:

    ‘This device is not allowed to access your mirror.
    Please check your config.js or config.js.sample to change this.’

    What kind of entry could be missing?


  • Module Developer

    @psteimann said in Access MagicMirror with HTTP?:

    What kind of entry could be missing?

    Look at the very beginning of your config file. The Whitelist section



  • hi, Try to include your local IP subnet in the config file
    var config = {
    port: 8080,
    ipWhitelist: [“127.0.0.1”, “::ffff:127.0.0.1”, “::1”, “::ffff:192.168.0.1/24”, “192.168.0.1/24”],



  • @shashank

    OK, it works from my internal network now, just had to change the values to 192.168.1.1./24, thanks for this.

    Before, I tried IpWhitelist: [ ], as documented, but then MM2 was showing a black screen only.

    What I want to do is now to make it accessible from out of my place, so I did a port-forwarding in the router with a dns-service to the pi. But this does not work, same error like before at the local network. Current IP starts with 85… Can I add another entry or just edit one of the 192. value and if yes, which one?

    Thanks!

    Peter



  • @shashank

    I started MM2 with the console now:-) Thanks Mikle1.

    It works in the local network now as I wrote in the posting above. But I get an issue-report. Is this important?

    Whoops! There was an uncaught exception…
    { Error: listen EADDRINUSE ::: 8088
    at Object.exports._errnoException (util.js:1050:11)
    at exports._exceptionWithHostPort (util.js:1073:20)
    at Server.setupListenHandle [as _listen2] (net.js:1263:14)
    at listenInCluster (net.js:1304:12)
    at Server.listen (net.js:1402:7)
    at new Server (/home/pi/MagicMirror/js/server.js:26:9)
    at /home/pi/MagicMirror/js/app.js:219:18
    at loadNextModule (/home/pi/MagicMirror/js/app.js:168:5)
    at /home/pi/MagicMirror/js/app.js:163:6
    at Class.loaded (/home/pi/MagicMirror/modules/node_modules/node_helper/index.js:19:3)
    code: ‘EADDRINUSE’,
    errno: ‘EADDRINUSE’,
    syscall: ‘listen’,
    address: ‘::’,
    port: 8088 }
    MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?
    If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues
    Launching application.

    Greez Peter


  • Module Developer

    @psteimann you are already using port 8088, is there any program which is using that port? Or you executed mm twice at same time. Common pitfall is not killing pm2 and starting another npm (or node serveronly) for test…



  • @Sean Port 8088 is not used by another program and there Is no other port-forwarding to this port.

    8080 is used by my NAS, so I changed the standard-port to 8088 in the config.js

    i start mm2 automatically with pm2, thats correct. but I do not start it twice.

    do you mean to try to start another instance of mm2 with npm start?

    Thanks!


  • Module Developer

    @psteimann sorry for my poor English. You SHOUD NOT execute twice, before killing pm2.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.