Black screen



  • I have tried searching here and tried some things but I just do not get it working. Maybe someone smart can guide me in the right direction. After the latest upgrade I get the error like below when running pm2 log mm. I just have a blck screen now.

    0_1507898134539_error.PNG


  • Module Developer

    @planet4 said in Black screen:

    Maybe someone smart can guide me in the right direction.

    Hmm, that’s definitely not me but maybe I can help you.

    I cannot read the picture you posted so will ask you if there are any errors in your terminal when you try to launch the mirror? Errors in dev console?

    In any event, I hate to keep suggesting this, but it has helped many people like yourself. And, it only takes a few minutes to get up and running again.

    A manual installation of MM (not the automatic installer script)

    Yes, I suggest you do a manual installation. If you run the automatic installer script you may run into trouble again.

    Rename your current MagicMirror folder. Go to https://github.com/MichMich/MagicMirror and click on the green Clone or Download button on the right
    side of the window, then click on Download ZIP. Now you have a MagicMirror-master.zip file. Double Click the file. Inside is the MagicMirror-master folder. Move that file to your /home/pi folder. Rename that folder to MagicMirror. Then in your terminal, cd into the MagicMirror directory and run npm install. When that finishes, run npm start, also in the MagicMirror directory.

    At this point the mirror should run but you’ll likely get a “Create a config” message displayed. At which point you should do this.
    https://forum.magicmirror.builders/topic/4528/how-to-create-a-working-config-for-absolute-beginners

    Then back to your terminal, in the MagicMirror directory, run npm start. That should get your mirror running.

    Then you can copy your modules, 1 by 1 into the new MagicMirror/modules folder and the entries into your new config.js file.

    That should do it.



  • @Mykle1 Thanks, Solved. Deletet everything and started with a fresh config. Something was messed up.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.