MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

{HowTo} turn on/off your monitor (Time based, PIR/Button, App)



  • @cruunnerr I just redid step 2.2 with the alteration of screen_on/off.sh (instead of monitor) and the HDMI is still being disabled and giving me the “no signal” screensaver.

    How do I know that the chmod +x steps are actually making the script executable?



  • try the shell scripts without the python script.

    sh monitor_off.sh should show a black screen (not turning HDMI off)
    sh monitor_on.sh should disable the black screen.

    if this is working for u, then your pir.py script seems not being correct.

    the chmod +x step is necessary for the python script execute the shell scripts.

    But first try the commands above. If this doesn’t work, then i have to think about and search for a solution.
    But i tried it just a few seconds ago, and it works fine here



  • @cruunnerr for me $ sh monitor_off.sh returns the following
    sh: 0: Can’t open monitor_off.sh
    I then inputted $ nano monitor_off.sh and it’s empty when I just inputted the commands from your instructions. ¯_(ツ)_/¯



  • again one step closer 😃

    put in the content and save with “ctrl+x” and “y”

    try everything agin and report if u got trouble again 🙂

    edit:

    oh sorry. Aren’t we using “screen_on/off”?? 😃

    so try

    sh screen_off.sh should show a black screen (not turning HDMI off)
    sh screen_on.sh should disable the black screen.



  • I GOT IT! I stepped back a few steps with the module removed from the config.js file and it wouldn’t blank anymore so it made me think I had something wrong with the pir.py file.

    I looked into Paviro’s files in the PIR-Sensor folder and found in the node_helper.js file a reference to tvservice -o/p. I found where my xscreensaver was located /usr/bin/ and I had the node_helper file execute the xscreensaver instead of the tvservice.

    Bingo! No more “No Signal” bouncing around when the PIR-Sensor module kicks in! Many thanks to Cruunnerr for the help. Definitely could not have figured this out without you!


  • Project Sponsor Module Developer

    @hoofta

    Good work, mate! I like it. 🙂



  • @cruunnerr,

    Thank you so much! What a great ‘How-to’- Guide 🙂

    You and your post helped a lot. 🙂



  • hey all, im having a issue with my pir module. i have run the pir.py script and its constantly scrolling the … until i move and then it stops for a brief second, and when i load the module in my config file the screen just stays black. is this some kind of interference or do i just have it hooked up backwards or something?



  • @hnperkins if the script is working the opposite way round it could be that you have a pir board which uses inverted signals. The board I had originally worked this way. So when no motion is detected it gives you a 1 & when you move it gives you a 0. Instead of running the script try typing gpio read 0 (substitute the pin number you used here… remember gpio “wiring pi” numbering will be different to the number you input in your file. See https://pinout.xyz/). It only shows the current state so you need to keep putting this in as you move in front of the sensor to test it. Hit up + enter to “retype” the command quickly in the console.

    If this is the case then unfortunately the script will not work in your case… it’s written for true or 1 to be when movement is detected.

    If you use paviro’s module there is a configuration option to invert the input pin.

    As to the screen being black when starting mm. It’s probably an error in your configuration. Search the forum to find info on how to check the config as that has been well covered.



  • @randomnoise ok so when i do the gpio read command it always shows a 1, when i use a pin its not connected to it shows a 0, is this what you were talking about?


Log in to reply