Blank white display on local machine (pi)



  • Hi!

    I have a problem when trying to display the MM interface on the RPi. The server is up an running (no problems) and I can access it from any other machine in the network. Interface works perfectly there. However, when i try to access it locally on the RPi, all i get is a white blank page. Tried two different browsers now, Epiphani and Midori, both show the same blank page. I tried to access it using “localhost” as well as the actual private IP-Address directly (and the correct port => using the default port 8080). No luck.
    When using electron I get the error EADDRINUSE for address 0.0.0.0 (in this [1] file, line 70)… But I guess that’s not the actual problem because I cannot even access it, using the browser. However, I checked whether there actually are other programs blocking the socket using “lsof -i TCP:8080”. No entries there before pm2 starts (unless i acces sthe page with another machine of coarse)…
    I’m slowly running out of ideas now. I guess that there are maybe some compatibility problems between the server and the browsers on the RPi. Otherwise I cannot explain why it works on other machines.

    Is there maybe somebody who had the same (or a similar) issue, that can give me advice?

    I’ve found one post of a guy (Timo Pak) that had the same problem 2 years ago in the comments of this article [2]. He wrote about a zip-file he got from somebody that worked (very detailed haha).

    My platform is a RPi2 running Jessie.

    [1] https://github.com/MichMich/MagicMirror/blob/master/js/electron.js
    [2] http://michaelteeuw.nl/post/83188136918/magic-mirror-part-v-installing-the-raspberry-pi


  • Moderator

    You shouldn’t need to launch a browser to view MM. If you followed the extensive installation steps, it should come up by itself. If you are still having problems after that, let us know where it failed during the setup.



  • Wow haven’t come across these instructions yet. Seem quite detailed. I will give it a try as soon as possible and will let you know if it worked.
    Thanks for the quick reply :)


  • Moderator

    Just a note: that was written for an RPI 3, and you’re using an RPI 2. Some things might be different but overall it should work just the same.



  • Alright, initially I wanted to setup the MM next to Jasper [1] for TTS and STT, but then again I cannot find any use-case for that when the mirror already displays everything relevant by itself XD… Therefore, I decided to kill the whole Jasper stuff and made a clean install. With this it worked like a charm now. Should have taken a look at the modules in advance. I was not a ware of such an active community. Awesome stuff, thx a lot!

    @KirAsh4: Your instructions work perfectly for the RPi2 as well ;)

    [1] https://jasperproject.github.io/



  • there are already built tts and stt modules for magicmirror²


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.