MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

[MMM-NowPlayingOnSpotify] – Display the currently on Spotify playing song



  • Hey @raywo ,

    Thanks developing this module. It’s one of the first modules I tried to set up on my setup.

    Your instructions on how to configure very clear. Being new to MagicMirror I couldn’t get it to work fully, though. I finally figured out what I did wrong (I am still in the dark as to where I can find some useful logs): I installed your module to /home/pi instead of to the MagicMirror-folder.

    As I didn’t want to bother on finding out on how to uninstall, I simply moved the entire directory to the right place and the module seems to run fine now 😃



  • Awesome module! I’d been using the MMM-Scrobbler, but this is a better module in my opinion. Your instructions are clear and easy to follow as well! I really like how instant it is as well. I currently just set this up while on break at work, so I can’t check it out at home yet, but watching from a VNC, it is incredibly responsive! Thanks again sir!



  • Hey, very nice module and easy to install! Thanks!!!

    I have a little question. I use a google assistent speaker… and when i say my google assistent “stop spotify” the song which is paused be show on my MM.
    Can I hide the current song if it is paused for more than X minutes?

    Thanks


  • Module Developer

    @philreis This is unfortunately not possible. The waySpotify works is that no song is actually ever stopped but it is paused. That is why the API can’t differentiate between stopped or paused songs. The only way to force the display to show nothing is by quitting the Spotify client.



  • Loving this module so far.

    As a feature request, would you be able to add a Config option to hide the progress bar? I’m not updating every second, so it makes the bar look off when it’s not moving/updating.



  • Thank you very much. So nice to see on the mirror.



  • This post is deleted!


  • hey i followed all of the steps and pasted it in to my config but it dosent work 😞



  • `never mind i installed it on the wrong directory , great mod thx 🙂



  • This post is deleted!