MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

MMM-FHEM shows values from FHEM devices ...



  • Hi everyone
    I’ve tried to install and activate the MMM-FHEM module but with not to much success. There was actually no problem neither with the installation nor the configuration but I can’t get it running.

    FHEM is running on the Rpi.
    Here is my config.js.

    //FHEM
    		 {
        module: 'MMM-FHEM',
        position: 'bottom_bar',
        config: {
          host: ['localhost'],
          port: '8083',
          https: false,
          devices: [
                      { deviceName: 'ESPEasy_ESP_Test_DHT',
                        deviceReadings: [
                                          { name: 'Temperatur', icon: 'wi wi-thermometer', suffix: '°' },
                                          { name: 'sate', icon: 'wi wi-humidity', suffix: 'test%' },
                                        ],
                      },
                     
                    ],
        },
      },
    	
    	
    		
    		
    	]
    

    i hope you can help me.
    greetings from Germany


  • Module Developer

    @dominic remove the squared brackets from the host row.


  • Module Developer

    @Da-ne-ezy hi currently i have no time to research how to implement that from nodejs side.
    If someone has an idea, please do a pull request on github.



  • @BenRoe thanks for the answer. I have removed the squared brackets but it is still the same. The modul will not displayed. Do you have an other idea ?



  • Hi,
    I have a similar issue: after installing the module and adding it to the config.js I don’t see it on the screen. After a restart all other widgets are shown. I don’t even see an empty field or such where this widget should be shown 😞

    Am I missing anything maybe?

    For the sake of debugging, I’m trying to access a publicly available FHEM instance.

    {
    			module: 'MMM-FHEM',
    			position: 'top_bar',
    			config: {
    				host: 'http://fhem.waschto.eu',
    				port: '8083',
    				https: false,
    				devices: [
    					  { deviceName: 'FL_Temperatur',
    						deviceReadings: [
    										  { name: 'temperature', icon: 'wi wi-thermometer', suffix: '°' },
    										  { name: 'humidity', icon: 'wi wi-humidity', suffix: '%' },
    										],
    					  }
    				]
    			}
    		}
    

    Might I have made a mistake installing the dependencies? Is “sudo npm install underscore” or “request” not the right way to do it?


  • Module Developer

    @Da-ne-ezy try this.

    host: 'username:password@ip-of-your-fhem-server'
    

    Please let me know if it works.



  • @BenRoe Sorry doesn’t work for me. The module doesn’t even appear. My config should be fine…

       {
    	module: 'MMM-FHEM',
    	position: 'bottom_bar',
           config: {
    			host: 'xxxx:xxxx@xxx.xxx.xxx.xx',
    			port: '8083',
    			https: true,
    				devices: [
    					{ deviceName: 'WZ_Heizung_Clima',
    						deviceReadings: [
    						{ name: 'measured-temp', icon: 'wi wi-thermometer', suffix: '°' },
    						{ name: 'desired-temp', icon: 'wi wi-thermometer', suffix: '°' },
    									       ],
    					},  
    						],
    		},
    	},
    

  • Module Developer

    Too bad, someone mention this on the github ticket. https://github.com/BenRoe/MMM-FHEM/issues/2
    I don’t have the time to examine this problem. If someone can implement this, please let me know.



  • the Fix for you`r Problem might be:

    Disable csrfToken

    after 2 weeks of searching the Internet i found the post in this forum this helpt me to fix the same probelm.


  • Project Sponsor

    This post is deleted!