Autostart & turning off powersave



  • Hey all,

    I’ve made it all the way through the install and config and have everything running well. I’m in the final stages and am trying to get autostart on boot working and disable the Pi from powersaving the monitor (right now the monitor turns off after a few minutes and wakes after I move the mouse).

    I followed the instructions here: https://github.com/MichMich/MagicMirror/wiki/Auto-Starting-MagicMirror but its still autosleeping and does not start on boot.

    However, one thing I had trouble with was this step:

    Starting your MagicMirror with PM2

    Simply start your mirror with the following command:

    pm2 start mm.sh
    You mirror should now boot up and appear on your screen after a few seconds.

    Enable restarting of the MagicMirror script.

    To make sure the MagicMirror restarts after rebooting, you need to save the current state of all scripts running via PM2. To do this, execute the following command

    pm2 save
    And that’s all there is! You MagicMirror should now reboot after start, and restart after any failure.

    When I entered pm2 start mm.sh the magic mirror program started, but in order to be able to then enter pm2 save I had to control-Q to stop the program to be able to get back to the terminal window. I’m not sure if that is the reason things are not working, or if there is another way I was supposed to do this?

    In doing my research, I also followed the instructions here: https://github.com/MichMich/MagicMirror/wiki/Auto-Starting-MagicMirror
    and changed the autostart file based on these instructions:

    Edit 2015/3/2: As commenter Roland points out, please use the following file in the new Raspian version: /etc/xdg/lxsession/LXDE-pi/autostart

    @xscreensaver -no-splash
    Additionally, I added the following lines:

    @xset s off
    @xset -dpms
    @xset s noblank
    @chromium --kiosk --incognito http://localhost

    Anyway, any help is appreciated, this is the one part of the install where I found conflicting instructions and somewhat confusing.

    Thanks,

    Nathan



  • There is apparently something in the Jessie version of Raspian that is not allowing these settings to take. My research has indicated that the easiest way to keep your Pi displaying data is to install the xscreensaver and then configure it to never shut down the screen.
    sudo apt-get update
    sudo apt-get install xscreensaver

    Note: I haven’t tried this myself yet. Do let me know if this works for you.



  • I had the same troubles. The only thing that worked was:

    @chengstark said in Screen keeps going to black after a few minutes.:

    run
    nano /home/pi/.config/lxsession/LXDE-pi/autostart
    Comment out (put a # in front of) the lines that are already in the file and add these 4 lines.

    @xset s off
    @xset -dpms
    @xset s noblank
    @midori -e Fullscreen -a http://localhost/MagicMirror/index.php
    

    This will disable the screensaver and start the magic mirror on boot and skip loading the LXDE GUI.

    quoted from “https://www.reddit.com/r/raspberry_pi/comments/3oktfu/magic_mirror_how_to/


    Note from admin: Please use Markdown on code snippets for easier reading!

    the only problem with this is, that you deactivate the GUI. (without commenting out the lines, it didn’t worked in my case…)

    EDIT: the @midori-line can be skipped :-)



  • Hi,

    I´m thinking about the same Problem yesterday .The “Black screen” Problem. I found several guides to disable the black screen. The guide which was post by @bhepler ,too. On an other Webpage was written you only have to edit /etc/kbd/config. There should written: BLANK_TIME=30. A User explain he had change this to BLANK_TIME=0. That will help. I haven´t test it but maybe it will be help.

    Later today I will test it,too

    Greets gismo



  • Ok i have checked this fast. I found this part:

    "# screen blanking timeout. monitor remains on, but the screen is cleared to

    range: 0-60 min (0==never) kernels I’ve looked at default to 10 minutes.

    (see linux/drivers/char/console.c)

    BLANK_TIME=30"

    I think you only have to delete the 30 an post a 0.

    Maybe someone can explain me, how I have to post code correctly. :-)



  • Hey all, well, I tried every config file change that is out there, including the ones suggested above, none worked for me (I’m on a Pi 3).

    What finally worked is this:

    In the terminal window type: “sudo apt-get install xscreensaver” .

    It will install a screen saver that you can then access from the menu. Go in and disable the blank screen.

    This is the only thing that worked for me and my screen has been on for an hour now.

    Hope it helps someone.

    Nathan



  • We should gather all the relevant information and combine them in a big tutorial.
    For example i also miss some reference to unclutter to hide the mousecursor.
    For early beginners it should be as easy as possible… Maybe i will work on that the next weeks. :-)



  • @deadherring said in Autostart & turning off powersave:

    What finally worked is this:
    In the terminal window type: “sudo apt-get install xscreensaver” .

    It will install a screen saver that you can then access from the menu. Go in and disable the blank screen.

    This is the only thing that worked for me and my screen has been on for an hour now.

    @deadherring Heh. I tried that. But then the screensaver activated and I got a lovely fiber optic flower on top of my my mirror interface. I’ll look into it again.

    Edited to add: Whoops. Never mind. I wasn’t looking in the right place. I tried setting “Blank After X minutes” and it wouldn’t let me set it to zero.
    0_1476205841539_screensaver.png



  • Yup, that was the setting that I found too. Did it work for you?



  • @deadherring Give me an hour and I’ll let you know. :-)


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.