First Steps



  • Hey
    i wanted creat my mirror automatically installation (curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh | bash)
    i did it via ssh and i got that fault (http://www.bilder-upload.eu/show.php?file=7554b1-1477179229.jpg)
    i have node v6.8.1
    npm 3.10.8
    maybe it doesn’t pi compatibilty?

    maybe a better picture: http://www.bilder-upload.eu/show.php?file=d5ee11-1477181137.png
    what can i do ?
    for any answer thanksfull.



  • @geeflaxx it canf find the library on your system

    try sudo apt-get install libgtk2.0-0



  • i tried it
    but now i have the fault that libXss.so.1 is missing
    i google it but i didn’t find a good answer…
    which library should i download now ?
    i have many screen’s and i hope you can help me 😕
    (i used the multiupload picload.org)
    https://pl.vc/nlwkl
    https://pl.vc/6jqck
    https://pl.vc/1lpl8h
    https://pl.vc/sesey

    thats my npm-debug.log

    • 0 info it worked if it ends with ok
      1 verbose cli [ ‘/usr/local/bin/node’, ‘/usr/local/bin/npm’, ‘start’ ]
      2 info using npm@3.10.9
      3 info using node@v6.8.1
      4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
      5 info lifecycle magicmirror@2.0.0~prestart: magicmirror@2.0.0
      6 silly lifecycle magicmirror@2.0.0~prestart: no script for prestart, continuing
      7 info lifecycle magicmirror@2.0.0~start: magicmirror@2.0.0
      8 verbose lifecycle magicmirror@2.0.0~start: unsafe-perm in lifecycle true
      9 verbose lifecycle magicmirror@2.0.0~start: PATH: /usr/local/lib/node_modules/npm/bin/node-gyp-bin:/home/pi/MagicMirror/node_modules/.b$
      10 verbose lifecycle magicmirror@2.0.0~start: CWD: /home/pi/MagicMirror
      11 silly lifecycle magicmirror@2.0.0~start: Args: [ ‘-c’, ‘electron js/electron.js’ ]
      12 info lifecycle magicmirror@2.0.0~start: Failed to exec start script
      13 verbose stack Error: magicmirror@2.0.0 start: electron js/electron.js
      13 verbose stack spawn ENOENT
      13 verbose stack at ChildProcess. (/usr/local/lib/node_modules/npm/lib/utils/spawn.js:33:16)
      13 verbose stack at emitTwo (events.js:106:13)
      13 verbose stack at ChildProcess.emit (events.js:191:7)
      13 verbose stack at maybeClose (internal/child_process.js:877:16)
      13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
      14 verbose pkgid magicmirror@2.0.0
      15 verbose cwd /home/pi/MagicMirror
      16 error Linux 4.4.21-v7+
      17 error argv “/usr/local/bin/node” “/usr/local/bin/npm” "start"
      18 error node v6.8.1
      19 error npm v3.10.9
      20 error file sh
      21 error code ELIFECYCLE
      22 error errno ENOENT
      23 error syscall spawn
      24 error magicmirror@2.0.0 start: electron js/electron.js
      24 error spawn ENOENT
      25 error Failed at the magicmirror@2.0.0 start script ‘electron js/electron.js’.
      25 error Make sure you have the latest version of node.js and npm installed.
      25 error If you do, this is most likely a problem with the magicmirror package,
      25 error not with npm itself.
      25 error Tell the author that this fails on your system:
      25 error electron js/electron.js
      25 error You can get information on how to open an issue for this project with:
      25 error npm bugs magicmirror
      25 error Or if that isn’t available, you can get their info via:
      25 error npm owner ls magicmirror
      25 error There is likely additional logging output above.
      26 verbose exit [ 1, true ]


  • i haven’t the error after i use
    ’‘sudo apt-get install libxss1 lsof’

    but now i have a new one, the same error but with the code that “libgconf-2.so.4” is missing

    why isn’t so many pakets install?



  • @geeflaxx is your raspbian version up to date?



  • i remove the order MagicMirror and install it automatically

    npm WARN grunt-yamllint@0.2.0 requires a peer of grunt@~0.4.0 but none was installed.
    Dependencies installation Done!

    We’re ready! Run DISPLAY=:0 npm start from the ~/MagicMirror directory to start your MagicMirror.

    i look the error in my installation is red ’ UNMET PEER DEPENDENCY grunt@1.0.1’

    and now i use 'npm start’
    the same error
    libgconf-2.so.4 is still missing
    if i use sudo apt-get install libconf-2-4
    E: Unable to locate package libconf-2-4

    i think it’s the false access i don’t have the rights cause (permission deniedmaybe)?

    or i think too that i haven’t the electron-prebuilt pakets ?



  • @strawberry-3-141 please help me

    okay i think my script electron js/electron.js is destroy

    i installed with sudo apt-get install libconf2-4 and it’s work
    but if i started npm the same error but with 'libnss3.so
    http://www.bilder-upload.eu/show.php?file=99f2e4-1477258272.png
    i am so desperately, i think i use the problem but the same come with another code…

    http://www.bilder-upload.eu/show.php?file=967e7b-1477258720.png
    why is that red?



  • @geeflaxx there must be something wrong with your whole setup. i would personally go and do it again with this instructions https://forum.magicmirror.builders/topic/236/complete-setup-tutorial