MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

Can you help me about this error



  • 0_1533074016234_2018-07-31-234814_1080x1920_scrot.jpg
    I don’t know why ?
    is it a module ?
    witch one ?
    thanks


  • Module Developer

    @fonfon

    Are you getting this error with the default modules only? Disable all other modules and see. Then add one at a time to see which generates the error.



  • Hi Mykle1,

    Indeed by elimination I think I can find the module that generates this error

    i try this thanks .
    and after if is it a module ?



  • @fonfon

    I had that error a few times, it was always an error in the config.js file. use a Js Linter to help you find the errors.



  • @justjim1220 thanks i use jshint.com no error



  • @fonfon

    next thing to try it to npm install in each individual module directory

    then npm rebuild in the MagicMagic directory

    let me know if that helps!


  • Module Developer

    @fonfon

    Did you determine which module is causing the error?



  • @mykle1 Thanks mykle1 but no !
    for desactivate a module i cut/paste the folder on the desktop then i restart the MM is it the good method ?
    because when i have no module its ok no error
    only with pir module its good
    but after with wunderground or google maps traffic module i have a lot of error or other…
    i don’t understand !!
    this after the update in 2.4.1.


  • Module Developer

    @fonfon said in Can you help me about this error:

    is it the good method ?

    This is how I disable modules without copying and pasting and moving things around. You can simply add disabled: false, at the beginning of all your config.js entries. true will disable the module.

    {
                disabled: false,
                module: 'MMM-EventHorizon',
                position: 'bottom_left',
                config: {
                    date: "2018-09-17", // (YYYY-MM-DD)  Date timer will end
                    time: "00:01:00", // (HH:MM:SS)    Exact time you want timer to end
                    text1: "Lucy's Birthday", // 2 lines of text during timer
                    text2: "Tempus Fugit", // 2 lines of text during timer
                    endText1: "Lucy is 1 today!", // 2 lines of text when timer ends
                    endText2: "What a big girl!", // 2 lines of text when timer ends
                }
            },
    


  • @fonfon

    no need to cut/paste each module…

    you can add

    disabled: false
    

    above each module, like this…

    {
        disabled: false,
        module: "clock",
        position: "top_center"
    },
    

    then, you can change it to true to shut off the module.

    it would be the easiest way to determine which module is causing the issue.
    load all your modules back into the config.js,
    add the code above,
    make all the default modules ‘false’,
    and all the rest ‘true’,
    refresh your mirror,
    if you still get the same issues,
    turn off the mirror and your terminal,
    maybe even restart your computer,
    then open your terminal,
    restart the mirror with 'npm start -dev’
    this will give you an error log, find that and post it in here,
    this would be easier for us to help you