MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

upgrade to 2.4.1problems and solutions



  • Ok so i did an upgrade to version 2.4.1 (with the Raspi Config changes as well) and all my hardware modules stopped working so i had to do a “npm install” on all of them (MMM-DHT-Sensor, MMM-Swipe, MMM-PIR-Sensor) but it only worked after doing a “rm -rf node_modules” inside each respective module and than “npm rebuild” and/or “npm install” … anyhow i got them to work finally with one draw back my MM is running flawless but in server mode only.

    I can not get it to display on its own display connected straight with hdmi and its own keyboard and mouse…but if i log on through a web browser http://magicmirror:8080 its there working just fine.

    What is the command i got to type to get both client and server running on the same Rpi?/
    Thank you
    Denis


  • Project Sponsor

    @richland007 - You’ll want to change into the magic mirror folder and tell npm to start the application.

    cd /home/pi/MagicMirror
    npm start
    

    The normal MagicMirror process includes the server. So if you can see the interface on your mirror, it’s also hosting the server.



  • @bhepler Thats how i start it every time but it does not display on my Rpi… only if i log on to it from a remote computers web browser or its own web browser i am able to see the content.
    So basically it is running on Server Mode Only not both server and client / user
    D



  • Anybody please …how do i get my Rpi to run both server and client of MM??? whats the command???.. for some reason the new installation is running just fine but server only.
    Can anyone tell me what the command is??

    Denis


  • Project Sponsor Module Developer

    @richland007

    This is a shot in the dark. I think I’ve seen somewhere on the forum that by disabling the updatenotification module you may be able to see MM running on your Pi.

    If this does not work then accept my apologies. Your post seemed a little bit desperate and this is not difficult to try.



  • @mykle1 Nope no luck that did not do it. Disabling “updatenotifications” had no effect
    wth?? i am not getting it i had to go through hell to update to the new version and now i am stuck with this problem
    What else can i do
    Denis



  • If i do a npm rebuild or npm install under MagicMirror in the initial run meaning if you npm start it says something like;
    MESA Loader failed to start lgr
    … or something to that nature 2 times than it loads just fine and it does not happen the second time that you restart the MM
    i think it has to do with the settings on the Open GL when you tweak the Rpi settings
    Denis


  • Module Developer

    @richland007 said in upgrade to 2.4.1problems and solutions:

    i think it has to do with the settings on the Open GL when you tweak the Rpi settings
    Denis

    A lot of people recently had issues with OpenGL.
    Do you only get a black sceen? Turn OpenGL off then. You don’t need it necessarily. For me it worked again afterwards. Still thinking about how to be able to activate OpenGL.

    And: If you need help, it is better to get into more detail first hand.



  • Yes it is confirmed that it is Open GL fault if you follow Raspberry Pi configuration changes here: Configuring the Raspberry Pi the real driver does not work at all the display just stays black …
    and with the fake driver option magic mirror will run on server mode only .

    If you take out the Open GL driver the mirror will run as it is supposed to but you will see a spike in cpu usage from around 20% with the fake kms driver to over 75% with the regular Rpi driver.

    How do we solve this and has anyone else had this issue other than me and @lavolp3 ??

    Thank you
    Denis



  • Another thing i have noticed is that configuring the settings to Disable WiFi Power Save on Rpi 3 (Stretch) will brake automatic connection to the router in a weird way … meaning after a reboot the Rpi will associate itself to a wireless network that you have previously signed on to but there is no internet access … you have to manually disconnect from the network and connect back on for internet to start working !!! which is definitely not ideal for a automatic run of raspberry pi !!

    Has anyone else had this issue??

    D


Log in to reply