SSH Connection failed (terminal (Mac) to Raspberry)



  • Hello Guys,

    since several day I am trying to lock into my raspberry 2 Model B V1.1 via the SSH Connection.
    Nevertheless the raspberry does not accept the standard password. I ve tried to reset the standard password several times. But it is not working.

    I am using the following command:

    “sudo ssh pi@raspberry”

    After that he won’t accept my password. The internet research did not help to fix my problem. Maybe you ve got a great hint.

    Thanks a lot and many greetings from Germany :)



  • Did you ever change the password?
    Were you able to successfully log in via SSH prior to your troubles?

    If the password has been changed without your knowledge, that is a very bad sign. I suggest pulling the card, reformatting it, re-flashing it with Raspbian and starting from scratch.



  • @bhepler I thought the same :-D

    I reformator the SD card, installed the software again and as you said doing it from the scratch.

    Nevertheless, I am not able to log in via “sudo ssh pi@raspberry”, because the standard password is not working. I googled the whole day trying to find a way out. If I will find a way, I ’ ll post it later :)



  • @PaulB You can flash the card, but once it’s in the Pi, you can’t SSH to it?

    Are you receiving a login prompt at all, or is the connection failing? Have you tried SSH to the IP address of the Pi? ssh pi@192.168.0.3 (or whatever).

    Does anyone remember if SSH is enabled on Raspbian by default? Or must you log in to the Pi itself and configure it?


  • Moderator

    The SSH server is enabled by default on a Raspbian image. And none of the security settings are enabled by default, leaving it to accept connections.

    The default login is 'pi' with password 'raspberry'. If you are unable to log in to the rpi from a remote connection with those credentials, then you are using an invalid/corrupt/hacked image. I recommend downloading it fresh from www.raspberrypi.org.

    The fact that you said you are using sudo to SSH into the rpi tells me you are attempting to connect from a different unix machine. Is this true? For one, you do not need sudo to issue SSH commands as a regular user. And second, where are you attempting to connect FROM?


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.