MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Resolution Problem Help



  • So I made my magicmirror as an innovation project, everything went smooth till i made the frame, now my clock and weather modules are cropped of the top of my screen as the frame covers the top and the bottom of the screen, i tried to move the clock and the weather using Top_right etc… and that didnt help, i tried also re-positioning them using the custom.css file ex : .clock and i seem to not figured how to do it right so that also didnt work for me too, as last resort i tried to install a new module and move it at the top of my screen so my clock and weather will shift down a little bit but that also went horribly wrong . that goes for the news feed that is in the bottom of my screen. and one more thing the font for compliments are way too big so i tried to resize it from the config file but when i did the letters went above each others, cuz i want the compliments to be in one line only .

    4_1541966509336_d07d6b0b-57a2-443f-a8b8-54048a29da43.jpg 3_1541966509336_ce9809ed-5494-47d2-b569-80ab5bf347d8.jpg 2_1541966509336_ac2e8b0f-a144-4aa3-8032-1434daca17ed.jpg 1_1541966509335_97bf4b28-ca67-4a93-b430-38762c9108b9.jpg 0_1541966509322_83a3fc95-941a-421e-9b59-0998e59aba14.jpg

    i really would appreciate any help


  • Project Sponsor Module Developer

    @isoshy

    I can help you with the border problem. You can add this to your custom.css file and adjust accordingly. It will move the borders of the display inside the frame that is covering them when done correctly. Just play with those values. It should be close already, judging by your pictures.

    body {
       margin: 20px;
       height: calc(100% - 40px);
       width: calc(100% - 40px);
     }
    


  • ty very much, that solved my problem, i love you

    it’s not a necessary thing but how do i make the complements in one line instead of three


  • Project Sponsor Module Developer

    @isoshy said in Resolution Problem Help:

    i love you

    Interesting! Thank you, I think. 🙂

    the compliments module is meant to be used in

    position: "lower_third", of your config. I would check that first. I should also ask if you changed the size of the font classes?

    Assuming you haven’t changed anything there then you could try classes: "thin medium bright", or classes: "thin large bright", in your config. Example:

    {
                disabled: false,
                module: "compliments",
                position: "lower_third",
                config: {
                  classes: "thin medium bright",
                }
            },
    

    By the way, this information is in the readme of the module. You should read the module readme’s. 😉