Application not starting when OpenGL is enabled



  • Re: [RasPi2] Application not starting when OpenGL is enabled

    I have the same problem as described above. The MM does not start.

    > sh run-start.sh
    
    libGL error: MESA-LOADER: failed to retrieve device information
    MESA-LOADER: failed to retrieve device information
    MESA-LOADER: failed to retrieve device information
    Starting MagicMirror: v2.5.0
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    Initializing new module helper ...
    Module helper loaded: updatenotification
    No helper found for module: clock.
    Initializing new module helper ...
    Module helper loaded: calendar
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper ...
    Module helper loaded: newsfeed
    All module helpers loaded.
    Starting server on port 8080 ... 
    Server started ...
    Connecting socket for: updatenotification
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started ...
    Launching application.
    
    

    And I have not a PIR Module installed too. The MM is absolute new installed and still nothing configured.

    Does anyone have an idea why it does not start?

    Thank you in advance



  • @klinge I think the appilcationstarts but on server mode only at least thats what it was doing on my case…go on a different computers webbrowser and type your mirrors RaspberryPi IP address and :8080 as the port number http://raspberrypiIP:8080 and see what you get.

    I did not find a solution to it i just took OpenGL out of the equation and it works fine

    Denis


  • Module Developer

    Try this
    npm start — —disable-gpu
    is - -(dash twice.) I’m not sure disable or disabled. Try both.



  • Thank you for your advice. I will try it on Monday



  • I tried both. …disable-gpu unfortunately does not not bring any improvement. So I took OpenGL out of the equation and it works.



  • I have the same problem. When OpenGL is enabled the application freezes at launching and I must unplug my pi from power and plug it back. I even tried to update electron to a newer version but I got another error there so I end up disabling OpenGL again.


  • Module Developer

    Just use serveronly (node serveronly) instead npm start.



  • @sean Thank you for your fast reply. I’ll give it a try as soon as I get home and see how it goes.



  • Are you using pm2? I was having same issue, and was able to resolve by following pm2 setup process.



  • OpenGL causes nothing but problems on the Pi I had to go back to legacy, full GL caused locked up the Pi causing black screen from the start of the MM, Fake GL caused MMM-voice not to work, so had to go back to legacy and all problems above gone