MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

MMM-Nest-Status - New module for your Nest thermostats and protect smoke detectors!



  • @michael5r no freaking way! You’ve made another module I have to have lol 😂



  • The modules not update after the recent upgrade ???


  • Project Sponsor Module Developer

    @michael5r

    Could you give an example of how this is added to the config.js? Please and thank you.

    electronOptions: {
        webPreferences: {
            webSecurity: false
        }
    }
    

  • Module Developer

    @mykle1 said in MMM-Nest-Status - New module for your Nest thermostats and protect smoke detectors!:

    @michael5r

    Could you give an example of how this is added to the config.js? Please and thank you.

    electronOptions: {
        webPreferences: {
            webSecurity: false
        }
    }
    

    Sure - it’s just another object, just like modules:

    0_1544975211760_0b3046c5-0fa1-416a-a1cc-efd9f7065e54-image.png


  • Module Developer

    @culi831 said in MMM-Nest-Status - New module for your Nest thermostats and protect smoke detectors!:

    The modules not update after the recent upgrade ???

    Both the nest-status and nest-cameras modules should be working just fine - what issue are you having?

    Bear in mind that the latest 1.3.0 update added socket notifications for data - which means you will need to restart your MagicMirror application in order for it to receive data, you can’t just reload the browser page (you’ll only have to do this this one time, though).


  • Project Sponsor

    Your first module you say? Wow. Coming in strong right out of the gate. Well done!



  • Love the screenshots, its exactly what I am looking for for a dashboard. However I cannot get it to load. I have gone through as much troubleshooting as I can think of, including starting over from scratch with a new RPi image.

    I go through the steps for setup and enter the numbers necessary from my Nest Developer account, PIN etc. It gives me the attached response with a token.
    0_1545141113701_53132113-c340-42bf-b837-e02d56c77fb4-image.png

    The issues that the token comes across as

    token:"c.Ythenabunchofletters
    thoseletterscontinue }
    }
    

    So my question is - is the "c. part of the token? I have tried copying the whole thing and it throws an error when reloading MM.

    module: "mmm-nest-status",
    position: "lower_third",
    config:  {
                   token:"c.Yblah
    moreletters           }
    }
    

    I have tried copying the "c.yblah without an end quote and add a , and it throws an error.

    token:"c.Yblah,
    

    When I run config:check in MagicMirror folder it says there are no syntax errors but when I reload MM it throws an error.

    I have tried adding a " to the end and a , and MM loads, but my icon looks like this:

    token:"c.Yblah",
    

    0_1545141896559_0ed056eb-08d0-4ad3-a79b-0287d8f391af-image.png
    The README shows as an int for the type so I should not need the " ", but thats the only way to make MM load.

    I have also tried all of the above steps without the c. and it still shows the loading icon.

    I apologize if this is something very simple that I just cannot figure out, so any help would be appreciated.



  • @phideltdexter said in MMM-Nest-Status - New module for your Nest thermostats and protect smoke detectors!:

    Love the screenshots, its exactly what I am looking for for a dashboard. However I cannot get it to load. I have gone through as much troubleshooting as I can think of, including starting over from scratch with a new RPi image.

    I go through the steps for setup and enter the numbers necessary from my Nest Developer account, PIN etc. It gives me the attached response with a token.
    0_1545141113701_53132113-c340-42bf-b837-e02d56c77fb4-image.png

    The issues that the token comes across as

    token:"c.Ythenabunchofletters
    thoseletterscontinue }
    }
    

    So my question is - is the "c. part of the token? I have tried copying the whole thing and it throws an error when reloading MM.

    module: "mmm-nest-status",
    position: "lower_third",
    config:  {
                   token:"c.Yblah
    moreletters           }
    }
    

    I have tried copying the "c.yblah without an end quote and add a , and it throws an error.

    token:"c.Yblah,
    

    When I run config:check in MagicMirror folder it says there are no syntax errors but when I reload MM it throws an error.

    I have tried adding a " to the end and a , and MM loads, but my icon looks like this:

    token:"c.Yblah",
    

    0_1545141896559_0ed056eb-08d0-4ad3-a79b-0287d8f391af-image.png
    The README shows as an int for the type so I should not need the " ", but thats the only way to make MM load.

    I have also tried all of the above steps without the c. and it still shows the loading icon.

    I apologize if this is something very simple that I just cannot figure out, so any help would be appreciated.

    So yours is like this try belows config just put in your token number

    {
    module: ‘mmm-nest-status’,
    position: ‘bottom_left’, // pick whichever position you want
    config: {
    token: “c.XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX”,
    displayMode: ‘all’,
    displayType: ‘list’,
    thermostatsToShow: ‘all’,
    units: ‘metric’,
    thermostatSize: ‘small’,
    alignment: ‘left’,
    // … and whatever else configuration options you want to use
    }
    },


  • Module Developer

    @phideltdexter My bad - there’s a typo in the Read Me, the token should be a string, not an int (I have updated the module now to reflect this).

    Try this in your config:

    {
        module: "mmm-nest-status",
        position: "lower_third",
        config: {
            token: "c.XXXXXXXXXX",
        }
    },
    

    where, of course, you replace c.XXXX with your actual token.



  • @michael5r

    Just wanted to update you. I needed to update both the mmm-nest-status and MM overall and now it appears to be working fine. Thank you for your clarification!

    0_1545251500930_7743642c-42de-4207-af76-7d84e60c458b-image.png