Stop the screensaver!



  • Thanks everyone for the erplies. I am still having the same issue, but doing some more testing and reading. I found this post:

    http://www.geeks3d.com/hacklab/20160108/how-to-disable-the-blank-screen-on-raspberry-pi-raspbian/

    In theory, just modifying the lightdm.conf should do the trick with newer versions of Raspbian Jessie Lite. I will poke around some more, hopefully i find a fix, so I can provide something back to this community.



  • Hi all,

    after doing this

    Disable the screensaver:
    Go to LXDE-autostart config:

    sudo nano /etc/xdg/lxsession/LXDE/autostart

    add the following lines:

    @xset s noblank
    @xset s off
    @xset -dpms

    Save and close, using the commands CTRL-O and CTRL-X.

    Go to lightdm.conf:

    sudo nano /etc/lightdm/lightdm.conf

    add the following lines in section [SeatDefaults]:

    xserver-command=X -s 0 -dpms

    The fucking screensaver is starting again.

    Then i do following:

    sudo apt-get install xscreensaver
    sudo apt-get remove xscreensaver

    An i never see a starting screensaver gain.

    Good luck!



  • So here is how I was able to fix my issue with the screen saver. I started this project following the tutorial from here:

    https://github.com/MichMich/MagicMirror/wiki/Jessie-Lite-Installation-Guide

    When you get to the Disable the ScreenSaver portion of the article, instead of changing the autostart file under

    /etc/xdg/lxsession/LXDE/autostart

    You should modify the autostart file under ~/.config/lxsession/LXDE/autostart

    sudo nano ~/.config/lxsession/LXDE/autostart

    Comment the first 3 lines (using a #), then add the same three lines listed in the tutorial. The final autostart file after all modifications should look similar to:

    #@lxpanel --profile LXDE
    #@pcmanfm --desktop --profile LXDE
    #@xscreensaver -no-splash

    @xset s noblack
    @xset s off
    @xset -dpms

    Once that is done, follow the instructions to modify the lightdm.conf file:

    sudo nano /etc/lightdm/lightdm.conf

    [SeatDefaults]
    xserver-command=X -s 0 -dpms

    Save the changes, reboot your raspberry pi (I am using an RPi3), and the screen saver is gone for good. Hopefully this helps someone else having the same issue.



  • @frog said in Stop the screensaver!:

    There’s no need for that attitude. Please desist as this is a forum for helping people. I also had this problem so it isn’t isolated. It may not be possible to add a keyboard and mouse to the screen and use the screensaver utility.

    Attitude? Oh you haven’t seen my attitude… just making a simple suggestion where there doesn’t need a case made out of it. It’s THE simplest way for NON programmers to do it…



  • I realize how (super) old this topic is, but for anyone who stumbles across it and still dealing with this, xscreensaver really is the easiest solution.

    sudo apt-get install xscreensaver

    Just change the screen saver in there to no screen saver, and you’re sorted.



  • Hey guys,

    there is another option on disabling the screensaver, which worked perfectly for me.
    Just disable the screensaver in the option menu of debian.

    Hope this helps someone 🙂



  • Revived again. I have xscreensaver installed and the screensaver disabled. It still blanks the screen after a day.



  • Hello,

    After a total reinstall of the recent raspberry to integrate Google Assist Pi, I also have the same problem.

    After watching, I end up with an empty screen after about 6 hours. I am forced to restart MagicMirror via the MMM-Remote-Control module.
    On the other hand I do not have xsceensaver of installed but the modification of the lines of command indicated in the wiki of installation of MM

    I did not experience this problem before. The only difference between my two installations is the 2.3.1 update of MagicMirror.
    Would it affect?

    Regards,



  • I had the same problem where. I stumbled across this thread, check out the answer given by JimmyN… it helped me at least.