MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

Flickering after 30-60 mins



  • MagicMirror always starts to flicker after 30-60 minutes. I tried on different monitors and only the monitor on HDMI starts to flicker.
    It looks like it’s only on HDMI, because if I connect via remote desktop, HDMI starts flickering but on remote desktop everything looks fine.
    If I use pm2 restart mm, MagicMirror restarts, the clock is counting about every 2 seconds, but the monitor doesn’t stop to flicker.
    After rebooting the PI everything works fine again. After 30-60 minutes same problem.


  • Project Sponsor

    This post may help you. At the very least, check out the YouTube link and let me know if the graphical errors you’re experiencing are the same.



  • I did have the same problem as @bhepler. Switching from fake KMS to full KMS solved the problem.

    Hein-Jan


  • Project Sponsor

    @rosenm Same problem for me.
    Only occured on my MM with the fake kms driver activated.
    I don’t know the reason yet.



  • @bhepler
    Thanks this solved it.
    Does anyone know why this is a problem with the fake one?



  • @hein-jan I had the same problem as well, switching from fkms to kms. When I switched to kms, the flickering went away, but I was unable to rotate 90 degrees for my vertical display.

    Have you come across any solutions? Or has anybody else? Thanks in advance for your insight!


  • Project Sponsor

    I had the problems after updating to 2.6.0 too. I noticed that the fading stuttered after the start of MM at the newsfeed module. After some time the whole monitor flickered like in the video.
    It helped me to comment out both kms drivers in the config.txt. The load of the system was also lower afterwards. The problem with the high load because of electron seems to be no longer present. At least for me.

    #dtoverlay=vc4-kms-v3d
    #dtoverlay=vc4-fkms-v3d
    


  • Hi how do I switch to the KMS drivers, I’m not noticing the flickers as my tv gets turned off, but have noticed memory on the Pi 3B+ is getting taxed big time and after about 2days the memory will go down to single figures before it just goes black screen, I’ve tried to use watchdog but that just crashes MM to desktop and doesn’t do the pm2 restart mm. Would switching to the KMS driver make it lighter? For me CPU usage is 1.something percent so it’s hardly using CPU but memory it’s killing it



  • @afrench10

    A small part of the MichMich set-Up instructions:

    ℹ️ Activating the Open GL drive can also be accomplished by using the raspi-config tool by running sudo raspi-config. Go to the Advanced Options menu and select A7 GL Driver. Next, select the G1 GL (Full KMS) OpenGL desktop driver with full KMS. Note that this option will be selected in the menu even when the GL drive is not yet configured.
    
    Unfortunately, as a result, the display_rotate=1 (see below) won't have any effect on the display. If you want to rotate the display when the Open GL driver is in use, we need to use the xrandr tool which allows us to rotate the display when in desktop mode. To do so, edit the autostart file:
    
    nano ~/.config/lxsession/LXDE-pi/autostart
    
    And add the following line:
    
    @xrandr --output HDMI-1 --rotate right
    

    That should solve your problem.

    Kind Regards

    Hein-Jan



  • @hein-jan Thanks for sending your reply! I saw that in the set-up instructions as well, but for some reason, I couldn’t get xrandr to rotate the display. I was curious if we needed the GL Driver at all, but based on recent comments in this thread, it seems that others don’t. I commented the Driver out and things seem to be working fine now. Thanks again!