MagicMirror² v2.6.0 is available! For more information about this release, check out this topic.

Raspbian Stretch: Screen is always blanked



  • Hello folks,
    I can’t get my RaspberryPi 2b with Raspbian Stretch to leave the display on permanently. I followed this instructions from GitHub and added the lines mentioned in the instruction to the files

    (I had to create the file and the path to the file “~/.config/lxsession/LXDE-pi/autostart”)
    I just found out that the location of the autostart file has changed: “/etc/xdg/lxsession/LXDE-pi/autostart”

    Raspbian still seems to turn off the display. MagicMirror still runs without problems. The logfile shows no errors and the website is accessible via (IP of the Raspberry):8080 and shows all modules there.

    Do you have any idea how I could proceed to troubleshoot?

    Greetings, André


  • Module Developer

    @a-i-ks

    Raspbian still seems to turn off the display.

    Personally, I would install xscreensaver and use that to disable the screensaver.

    In your terminal
    sudo apt-get install xscreensaver

    THEN
    sudo reboot

    Run xscreensaver. Choose Disable Screensaver. Done.