MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Installing on Pi 3B | Unable to install dependencies! | Error 128 in debug logs



  • OS: Raspbian Linux JARVIS 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux
    Issue: Unable to install dependencies! Error 128
    Description: Attempted running Auto installer with failure at dependencies. Received error listed below.

    9923 warn grunt-stylelint@0.10.1 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
    9924 warn acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.
    9925 verbose stack Error: exited with error code: 128
    9925 verbose stack     at ChildProcess. (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/util/finished.js:12:19)
    9925 verbose stack     at emitTwo (events.js:126:13)
    9925 verbose stack     at ChildProcess.emit (events.js:214:7)
    9925 verbose stack     at maybeClose (internal/child_process.js:925:16)
    9925 verbose stack     at Socket.stream.socket.on (internal/child_process.js:346:11)
    9925 verbose stack     at emitOne (events.js:116:13)
    9925 verbose stack     at Socket.emit (events.js:211:7)
    9925 verbose stack     at Pipe._handle.close [as _onclose] (net.js:567:12)
    9926 verbose cwd /root/MagicMirror
    9927 verbose Linux 4.14.79-v7+
    9928 verbose argv "/usr/bin/node" "/usr/local/bin/npm" "install"
    9929 verbose node v8.11.1
    9930 verbose npm  v6.7.0
    9931 error Error while executing:
    9931 error /usr/bin/git ls-remote -h -t ssh://git@github.com/patriksimek/vm2.git
    9931 error
    9931 error fatal: Could not change back to '/root/MagicMirror': Permission denied
    9931 error
    9931 error exited with error code: 128
    9932 verbose exit [ 1, true ]
    
    

    As this is my first time installing, I tried manually installing npm but with no luck. The error does say I need to install peer dependencies manually. I researched manually installing the peer dependencies to no luck. Any pointers?


  • Project Sponsor

    It looks like you’re attempting to install the Magic Mirror as the root user. You don’t want to do that. I would delete the /root/MagicMirrordirectory, change back to the pi and then install from the home directory of that user.



  • Thanks for getting back to me @bhepler! I ran it as the normal PI user but ran into this:

    Installing dependencies ...
    npm WARN deprecated time-grunt@2.0.0: Deprecated because Grunt is practically unmaintained. Move on to something better. This package will continue to work with Grunt v1, but it will not receive any updates.
    npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
    
    > electron-chromedriver@1.8.0 install /home/pi/MagicMirror/node_modules/electron-chromedriver
    > node ./download-chromedriver.js
    
    successfully dowloaded and extracted!
    
    > electron@2.0.16 postinstall /home/pi/MagicMirror/node_modules/electron
    > node install.js
    
    Downloading electron-v2.0.16-linux-arm.zip
    Error: read ECONNRESET
    /home/pi/MagicMirror/node_modules/electron/install.js:54
      throw err
      ^
    
    Error: read ECONNRESET
        at _errnoException (util.js:1022:11)
        at TLSWrap.onread (net.js:628:25)
    npm WARN grunt-stylelint@0.10.1 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.
    
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! electron@2.0.16 postinstall: `node install.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the electron@2.0.16 postinstall script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2019-01-25T18_59_27_944Z-debug.log
    Unable to install dependencies!
    
    

    Although, I got a little further this time around!



  • I was an idjit. I thought I had removed the directories but it seems there was another hidden one. We’re fine!


  • Project Sponsor

    @roskafarian Glad to hear it! Does that mean this issue is resolved?



  • Oh yes! We’re cooking with lighter fluid as we speak



  • In case you didn’t find a solution yet, a user by the name sdetweil just helped me with a similar problem with my RPi 3 B+ running the latest Rasbian Stretch.

    Here is the link to that discussion for everyone else who is stuck at this step too:
    https://forum.magicmirror.builders/topic/9636/stuck-at-unable-to-install-dependencies/8?page=1


Log in to reply