MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Divide Config.js into modules



  • @sean thats all cool, but will take significant rewrite of the core services…



  • @sdetweil said in Divide Config.js into modules:

    @artieikon require is not allowed in module.js, but you could use the getScripts function to load them

    Also

    Start mm in developers mode

    npm start dev
    

    Then select the console tab to see what’s going on in the modules
    Node_helpers display info in the terminal window

    You are amazing! thank you so much for this



  • @Sean
    Lazy loading is always a quality thing to have. Anything that takes away from startup times and pre-processing generally helps user experience greatly.

    I think it’s been overlooked because of the “hide modules using an orchestrater” so its not like functionality is being lost. But the benefit of it would still be there



  • @artieikon also, please create a config file is because of a syntax error in the config file…

    from the MM folder do

    npm config:check
    

    fix errors from the top down



  • @artieikon yeh, but generally people startup once and it runs for months…



  • @sdetweil

    npm run config:check
    

    but that actually came back valid since there are no syntax errors it just blew up on me runtime. The dev mode properly shows what is the issue though



  • I do two things myself to make it sane.

    1st, I use geany to edit. It’s a dream to work with, and keeps all my { with my } …

    2nd, I’ve reorganized my config file as follows (Config options and modules removed to protect secure data).

    /* Magic Mirror
     * Live Config
     * By Brendan Keyport
     */
    
    var config = {
    	modules: [
    // top_bar 
    // top_left
    // top_center 
    // top_right 
    // upper_third 
    // middle_center 
    // lower_third 
    // bottom_left 
    // bottom_center 
    // bottom_right
    // bottom_bar 
    // fullscreen_above 
    // fullscreen_below 
    // Hidden & Background
    // End modules before this line, do not edit below
    ]
    };
    if (typeof module !== "undefined") {module.exports = config;}
    


  • Stumbling though the process to get this working the way i want. Just felt like i should share.

    From what i surmise config.js is used both client side and server side. This is why “require” doesnt work and the browser complains. That is a server side construct and cannot be used client side.

    Cool whatever, we have other ways to do things. Next i started trying to use XMLHttpRequest.
    This blew up on me because electron does not support hitting the filesystem from the browser unless you set webSecurity to false. Cool this seems doable as we can pass in that value in the electronOptions in the config.js

    Here’s where the fun happens. This doesnt work because that is done server side and it also uses the same config.js. Server side it cant resolve XMLHttpRequest because you need a “requires” statement to get it but then that blows up client side.

    I can hack it in by specifying the webSecurity setting in the js/electron.js file as a default but that seems far too darn hacky. Im still stuck with the client showing the modules properly but the server not loading them… next try will be to run server only and client only with slightly different configs :vomit:



  • Got it working. Here is some simple code for anyone curious. There is probably a better way to get the same outcome, but this seems to work for now so I’m happy with it. Obviously this is rather useless currently, but I’m planning on iterating over a directory to pull out configs and parse them into modules, but i wanted to share the simple version first.

    config.js

    if (typeof window === 'undefined') {
    // Server side add requires here
            var XMLHttpRequest = require("xmlhttprequest").XMLHttpRequest;
    } else {
    // client side only code here
    }
    
    var Http = new XMLHttpRequest();
    var url = "file:///location/of/file/abc.txt";
    Http.open("GET", url, false);
    Http.send();
    
    var mods = [
            {
                    module: Http.responseText.trim(),
                    position: "top_left"
            },
    ];
    
    
    var config = {
            address: "0.0.0.0",
            port: 8080,
            ipWhitelist: [],
            language: "en",
            timeFormat: 12,
            units: "imperial",
            modules: mods,
            electronOptions: { webPreferences: { webSecurity: false } }
    };
    
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== "undefined") {module.exports = config;}
    

    abc.txt

    clock
    

    Notes:

    • Without specifying webSecurity: false Electron will not allow you to access a file that is not served up by the application. This is a security risk so use at your own discretion.
    • typeof window === 'undefined' is how I am figuring out if this code is executing server side or client side. Server side I had to add the require to be able to use XMLHttpRequest.


  • @lavolp3 said in MMM-Compliments doesn’t load:

    @stuartiannaylor yes that’s all you need in the config part.

    The module entry looks like this for me:

        },
            {
            //disabled: true,
            module: "compliments",
            position: "lower_third",
            config: {
                classes: 'small',
                remoteFile: 'xxxxxxx.json',
                updateInterval: 12*60*60*1000,
            }
        },
    

    As that is a top tip and ‘small’ ?
    Dont know what you mean with that. I think you don’t need to give it a class but with this class you can determine the size of the text.

    remoteFile is a file, not a folder. But it can be anywhere, however if it’s not in the module directory you ned to give the absolute path “/home/pi/…”