Sometimes random modules gets hidden



  • Hi everyone!

    I have started testing my MagicMirror, before putting everything together and mouting on the wall.
    Everything works fine, except one thing:
    Sometimes random modules (so lets say I have 8 modules, and 6-7 of them) gets hidden. Not all of them, not always the same modules, but they disappear. I can easily switch back them to visible in the MagicMirror Remote Control menu. So it really just gets hidden.

    What can cause this? Previously I have used ModuleScheduler module to hide and show modules based on time, but now all of my used modules support this by design, so I don’t need it. I have also deleted that module, but the issue is the same.

    Can someone help me?

    Thanks!



  • @radokristof No one? Still has this issues…


  • Module Developer

    We don’t know which modules you are using. We have no second-sights.
    Test by yourself with obsoleting(removing or outcommenting) some modules, then execute MM again. When some specific module is not included, there seems no problem, that module will be the suspect.
    Or tell us which modules you are using.


  • Project Sponsor Module Developer

    Check the log file. Search for hide or similar. Maybe there is a notification from somewhere that hides the modules.

    Also add the excellent MMM-Logging module to get time stamps in log file, helps a bit when debugging.



  • @retroflex Thanks I have added MMM-Logging. But I couldn’t see any information about this issue in the out.log (However the error log is quite big, around 300MB, is that normal?)

    2019-03-02T23:49:17   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-02T23:54:00   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T00:04:00   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T00:14:00   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T00:24:01   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T00:34:01   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T00:44:01   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T00:54:01   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T01:04:02   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T01:14:02   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    2019-03-03T01:24:02   payload: undefined (/home/pi/MagicMirror/modules/MMM-Logging/node_helper.js:34 Class.socketNotificationReceived)
    

    I’m having lots of infos like this… but nothing else, the issue is still there…

    I was able to capture when it disappears (I looking at it at the moment). It just the modules faded out, like someone hidden it. No crash, no restart, nothing spectacular…


  • Project Sponsor Module Developer

    @radokristof said in Sometimes random modules gets hidden:

    but now all of my used modules support this (hide and show) by design

    How so?



  • @Mykle1 It has it as a config parameter.

    Like MMM-MyCommute has hideDays, startTime, etc…



  • Now I was able to reduce the error a little bit. Now it seems that this happens only after a day or so, and if happens, not randomly, but every module got hidden, except the “currentweather, forecast” modules…



  • @radokristof same problem here…



  • @costascontis Sorry, haven’t seen your post. Since then, could you solved this?

    Which modules are enabled and shown on your mirror? I almost thought that this problem is gone, it was good for days, but I have seen it again yesterday.