Problem: npm install && npm start



  • Hi,
    I’m new to Raspberry and coding… :/
    So of yours I have some troubles.

    The automatic installations mode wouldn work out, so I tried manuell mode.

    Can you tell me what I need to chance or which information do need?

    Here’s the code:

    pi@raspberrypi:~/MagicMirror $ npm install && npm start
    npm WARN engine grunt-jsonlint@1.1.0: wanted: {"node":">=4.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine grunt-eslint@19.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine request@2.79.0: wanted: {"node":">= 4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine eslint@3.10.2: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine stylelint@7.6.0: wanted: {"node":">=4.2.1"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine stylelint@7.6.0: wanted: {"node":">=4.2.1"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine form-data@2.1.2: wanted: {"node":">= 0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine hawk@3.1.3: wanted: {"node":">=0.10.32"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})
     
    > electron-prebuilt@1.4.8 postinstall /home/pi/MagicMirror/node_modules/electron-prebuilt
    > node install.js
    
    npm WARN engine cosmiconfig@2.1.0: wanted: {"node":">=0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine string-width@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine get-stdin@5.0.1: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine postcss@5.2.6: wanted: {"node":">=0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine strip-bom@3.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine shelljs@0.7.5: wanted: {"node":">=0.11.0","iojs":"*"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine is-fullwidth-code-point@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine string-width@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine get-stdin@5.0.1: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine postcss@5.2.6: wanted: {"node":">=0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine cosmiconfig@2.1.0: wanted: {"node":">=0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine is-fullwidth-code-point@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine string-width@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine is-fullwidth-code-point@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN deprecated node-uuid@1.4.7: use uuid module instead
    npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine co@4.6.0: wanted: {"iojs":">= 1.0.0","node":">= 0.12.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine co@4.6.0: wanted: {"iojs":">= 1.0.0","node":">= 0.12.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine co@4.6.0: wanted: {"iojs":">= 1.0.0","node":">= 0.12.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    |
    > magicmirror@2.0.0 prepublish /home/pi/MagicMirror
    > npm run snyk-protect
    
    
    > magicmirror@2.0.0 snyk-protect /home/pi/MagicMirror
    > snyk protect
    
    Successfully applied Snyk patches
    npm ERR! peerinvalid The package grunt does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer grunt-eslint@19.0.0 wants grunt@>=0.4.0
    npm ERR! peerinvalid Peer grunt-yamllint@0.2.0 wants grunt@~0.4.0
    
    npm ERR! System Linux 4.4.21-v7+
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21
    npm ERR! code EPEERINVALID
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    

    Thanks alot



  • Hi,

    it seems, that your installed version of npm is very old.
    You can update it with the command npm install npm@latest -g

    I would recommend to update all the other packages as well. You can do that by:
    npm update

    After that, run npm install again.



  • Already made update and upgrade.
    Everything seems to be the newest version



  • I tried it again, if you find anything in my code… let me know?

    I’m not sure where to install npm… in the MagicMirror folder or above?

    pi@raspberrypi:~/MagicMirror $ cd
    pi@raspberrypi:~ $ sudo npm install npm@latest -g
    /usr/local/bin/npm -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
    npm@4.0.2 /usr/local/lib/node_modules/npm
    pi@raspberrypi:~ $ npm updte
    
    Usage: npm 
    
    where  is one of:
        add-user, adduser, apihelp, author, bin, bugs, c, cache,
        completion, config, ddp, dedupe, deprecate, docs, edit,
        explore, faq, find, find-dupes, get, help, help-search,
        home, i, info, init, install, isntall, issues, la, link,
        list, ll, ln, login, ls, outdated, owner, pack, prefix,
        prune, publish, r, rb, rebuild, remove, repo, restart, rm,
        root, run-script, s, se, search, set, show, shrinkwrap,
        star, stars, start, stop, submodule, t, tag, test, tst, un,
        uninstall, unlink, unpublish, unstar, up, update, v,
        version, view, whoami
    
    npm  -h     quick help on 
    npm -l           display full usage info
    npm faq          commonly asked questions
    npm help   search for help on 
    npm help npm     involved overview
    
    Specify configs in the ini-formatted file:
        /home/pi/.npmrc
    or on the command line via: npm  --key value
    Config info can be viewed via: npm help config
    
    npm@1.4.21 /usr/share/npm
    pi@raspberrypi:~ $ sudo npm update
    npm WARN npm npm does not support Node.js v0.10.29
    npm WARN npm You should probably upgrade to a newer version of node as we
    npm WARN npm can't make any promises that npm will work with this version.
    npm WARN npm You can find the latest version at https://nodejs.org/
    pi@raspberrypi:~ $ npm install
    npm ERR! install Couldn't read dependencies
    npm ERR! package.json ENOENT, open '/home/pi/package.json'
    npm ERR! package.json This is most likely not a problem with npm itself.
    npm ERR! package.json npm can't find a package.json file in your current directory.
    
    npm ERR! System Linux 4.4.21-v7+
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
    npm ERR! cwd /home/pi
    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21
    npm ERR! path /home/pi/package.json
    npm ERR! code ENOPACKAGEJSON
    npm ERR! errno 34
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/npm-debug.log
    npm ERR! not ok code 0
    pi@raspberrypi:~ $ sudo npm install
    npm WARN npm npm does not support Node.js v0.10.29
    npm WARN npm You should probably upgrade to a newer version of node as we
    npm WARN npm can't make any promises that npm will work with this version.
    npm WARN npm You can find the latest version at https://nodejs.org/
    npm WARN enoent ENOENT, open '/home/pi/package.json'
    npm WARN pi No description
    npm WARN pi No repository field.
    npm WARN pi No README data
    npm WARN pi No license field.
    pi@raspberrypi:~ $ cd MagicMirror
    pi@raspberrypi:~/MagicMirror $ npm install
    |
    > magicmirror@2.0.0 prepublish /home/pi/MagicMirror
    > npm run snyk-protect
    
    
    > magicmirror@2.0.0 snyk-protect /home/pi/MagicMirror
    > snyk protect
    
    Successfully applied Snyk patches
    npm ERR! peerinvalid The package grunt does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer grunt-eslint@19.0.0 wants grunt@>=0.4.0
    npm ERR! peerinvalid Peer grunt-yamllint@0.2.0 wants grunt@~0.4.0
    
    npm ERR! System Linux 4.4.21-v7+
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21
    npm ERR! code EPEERINVALID
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    pi@raspberrypi:~/MagicMirror $ cd
    pi@raspberrypi:~ $ npm update
    pi@raspberrypi:~ $ cd MagicMirror
    pi@raspberrypi:~/MagicMirror $ npm update
    
    
    npm WARN engine hawk@3.1.3: wanted: {"node":">=0.10.32"} (current: {"node":"0.10.29","npm":"1.4.21"})
    plur@1.0.0 node_modules/time-grunt/node_modules/pretty-ms/node_modules/plur
    resolve-from@1.0.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/require-uncached/node_modules/resolve-from
    speedometer@0.1.4 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/nugget/node_modules/progress-stream/node_modules/speedometer
    has-flag@1.0.0 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/postcss/node_modules/supports-color/node_modules/has-flag
    supports-color@2.0.0 node_modules/time-grunt/node_modules/chalk/node_modules/supports-color
    array-differ@1.0.0 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/multimatch/node_modules/array-differ
    get-stdin@4.0.1 node_modules/grunt/node_modules/dateformat/node_modules/get-stdin
    debug@0.7.4 node_modules/electron-prebuilt/node_modules/extract-zip/node_modules/debug
    ms@0.7.1 node_modules/express/node_modules/send/node_modules/ms
    css-color-names@0.0.3 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/colorguard/node_modules/pipetteur/node_modules/synesthesia/node_modules/css-color-names
    path-to-regexp@0.1.7 node_modules/express/node_modules/path-to-regexp
    punycode@1.3.2 node_modules/snyk/node_modules/url/node_modules/punycode
    punycode@1.4.1 node_modules/request/node_modules/tough-cookie/node_modules/punycode
    after@0.8.1 node_modules/socket.io/node_modules/engine.io/node_modules/engine.io-parser/node_modules/after
    is-arrayish@0.2.1 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/cosmiconfig/node_modules/parse-json/node_modules/error-ex/node_modules/is-arrayish
    throttleit@0.0.2 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/nugget/node_modules/throttleit
    map-obj@1.0.1 node_modules/grunt/node_modules/dateformat/node_modules/meow/node_modules/map-obj
    array-flatten@1.1.1 node_modules/express/node_modules/array-flatten
    isarray@0.0.1 node_modules/socket.io/node_modules/has-binary/node_modules/isarray
    strip-json-comments@1.0.4 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/rc/node_modules/strip-json-comments
    assert-plus@0.2.0 node_modules/request/node_modules/http-signature/node_modules/assert-plus
    foreachasync@3.0.0 node_modules/walk/node_modules/foreachasync
    debug@2.2.0 node_modules/express/node_modules/send/node_modules/debug
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/snyk/node_modules/snyk-policy requires es6-promise@'^3.1.2' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/snyk/node_modules/snyk-resolve-deps requires es6-promise@'^3.0.2' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    undefsafe@0.0.3 node_modules/snyk/node_modules/undefsafe
    eventemitter2@0.4.14 node_modules/grunt/node_modules/eventemitter2
    supports-color@2.0.0 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/chalk/node_modules/supports-color
    component-emitter@1.1.2 node_modules/socket.io/node_modules/socket.io-parser/node_modules/component-emitter
    extsprintf@1.0.2 node_modules/request/node_modules/http-signature/node_modules/jsprim/node_modules/extsprintf
    minimist@0.0.8 node_modules/grunt-eslint/node_modules/eslint/node_modules/mkdirp/node_modules/minimist
    caller-path@0.1.0 node_modules/grunt-eslint/node_modules/eslint/node_modules/require-uncached/node_modules/caller-path
    └── callsites@0.2.0
    isarray@0.0.1 node_modules/socket.io/node_modules/socket.io-parser/node_modules/isarray
    strip-json-comments@1.0.4 node_modules/grunt-eslint/node_modules/eslint/node_modules/strip-json-comments
    estraverse@4.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/esrecurse/node_modules/estraverse
    npm WARN engine postcss@5.2.6: wanted: {"node":">=0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    map-obj@1.0.1 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/meow/node_modules/map-obj
    camelcase-keys@2.1.0 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/meow/node_modules/camelcase-keys
    └── camelcase@2.1.1
    pluralize@1.2.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/pluralize
    rimraf@2.2.8 node_modules/grunt/node_modules/rimraf
    supports-color@2.0.0 node_modules/grunt-eslint/node_modules/chalk/node_modules/supports-color
    after@0.8.1 node_modules/socket.io/node_modules/socket.io-client/node_modules/engine.io-client/node_modules/engine.io-parser/node_modules/after
    chalk@0.4.0 node_modules/grunt-jsonlint/node_modules/jsonlint/node_modules/nomnom/node_modules/chalk
    ├── has-color@0.1.7
    ├── ansi-styles@1.0.0
    └── strip-ansi@0.1.1
    underscore@1.6.0 node_modules/grunt-jsonlint/node_modules/jsonlint/node_modules/nomnom/node_modules/underscore
    ipaddr.js@1.1.1 node_modules/express/node_modules/proxy-addr/node_modules/ipaddr.js
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-stylelint/node_modules/stylelint/node_modules/colorguard/node_modules/postcss-reporter requires chalk@'^1.0.0' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-stylelint/node_modules/stylelint/node_modules/colorguard/node_modules/postcss-reporter requires log-symbols@'^1.0.2' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-stylelint/node_modules/stylelint/node_modules/colorguard/node_modules/postcss-reporter requires postcss@'^5.0.0' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    color-diff@0.1.7 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/colorguard/node_modules/color-diff
    verror@1.3.6 node_modules/request/node_modules/http-signature/node_modules/jsprim/node_modules/verror
    supports-color@2.0.0 node_modules/grunt/node_modules/grunt-legacy-log/node_modules/grunt-legacy-log-utils/node_modules/chalk/node_modules/supports-color
    camelcase-keys@2.1.0 node_modules/grunt/node_modules/dateformat/node_modules/meow/node_modules/camelcase-keys
    └── camelcase@2.1.1
    uuid@2.0.3 node_modules/snyk/node_modules/tempfile/node_modules/uuid
    npm WARN engine postcss@5.2.6: wanted: {"node":">=0.12"} (current: {"node":"0.10.29","npm":"1.4.21"})
    finalhandler@0.5.0 node_modules/express/node_modules/finalhandler
    ├── unpipe@1.0.0
    └── statuses@1.3.1
    supports-color@2.0.0 node_modules/snyk/node_modules/chalk/node_modules/supports-color
    has-binary@0.1.6 node_modules/socket.io/node_modules/engine.io/node_modules/engine.io-parser/node_modules/has-binary
    └── isarray@0.0.1
    qs@6.2.0 node_modules/express/node_modules/qs
    async@0.9.2 node_modules/grunt-yamllint/node_modules/async
    string-width@1.0.2 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/nugget/node_modules/single-line-log/node_modules/string-width
    ├── code-point-at@1.1.0
    ├── strip-ansi@3.0.1 (ansi-regex@2.0.0)
    └── is-fullwidth-code-point@1.0.0 (number-is-nan@1.0.1)
    figures@1.7.0 node_modules/time-grunt/node_modules/figures
    ├── escape-string-regexp@1.0.5
    └── object-assign@4.1.0
    chalk@0.5.1 node_modules/grunt-yamllint/node_modules/chalk
    ├── ansi-styles@1.1.0
    ├── supports-color@0.2.0
    ├── escape-string-regexp@1.0.5
    ├── strip-ansi@0.3.0 (ansi-regex@0.2.1)
    └── has-ansi@0.1.0 (ansi-regex@0.2.1)
    path-exists@2.1.0 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/path-exists
    └── pinkie-promise@2.0.1 (pinkie@2.0.4)
    minimatch@3.0.2 node_modules/snyk/node_modules/snyk-recursive-readdir/node_modules/minimatch
    └── brace-expansion@1.1.6 (balanced-match@0.4.2, concat-map@0.0.1)
    snyk-module@1.7.0 node_modules/snyk/node_modules/snyk-module
    ├── hosted-git-info@2.1.5
    └── validate-npm-package-name@2.2.2 (builtins@0.0.7)
    async@1.5.2 node_modules/snyk/node_modules/hasbin/node_modules/async
    debug@2.2.0 node_modules/express/node_modules/debug
    └── ms@0.7.1
    has-binary@0.1.6 node_modules/socket.io/node_modules/socket.io-client/node_modules/engine.io-client/node_modules/engine.io-parser/node_modules/has-binary
    └── isarray@0.0.1
    doctrine@1.5.0 node_modules/grunt-eslint/node_modules/eslint/node_modules/doctrine
    └── isarray@1.0.0
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/es6-iterator requires d@'^0.1.1' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/es6-set requires d@'~0.1.1' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/es6-symbol requires d@'~0.1.1' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/event-emitter requires d@'~0.1.1' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/d
    glob@7.0.6 node_modules/grunt/node_modules/glob
    ├── inherits@2.0.3
    ├── fs.realpath@1.0.0
    ├── inflight@1.0.6 (wrappy@1.0.2)
    └── once@1.4.0 (wrappy@1.0.2)
    mkdirp@0.5.0 node_modules/electron-prebuilt/node_modules/extract-zip/node_modules/mkdirp
    └── minimist@0.0.8
    esprima@2.7.3 node_modules/grunt-yamllint/node_modules/js-yaml/node_modules/esprima
    yauzl@2.4.1 node_modules/electron-prebuilt/node_modules/extract-zip/node_modules/yauzl
    └── fd-slicer@1.0.1 (pend@1.2.0)
    es6-promise@3.3.1 node_modules/snyk/node_modules/snyk-try-require/node_modules/es6-promise
    os-name@1.0.3 node_modules/snyk/node_modules/os-name
    ├── win-release@1.1.1
    └── osx-release@1.1.0 (minimist@1.2.0)
    yargs@1.3.3 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/colorguard/node_modules/yargs
    redent@1.0.0 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/meow/node_modules/redent
    ├── strip-indent@1.0.1 (get-stdin@4.0.1)
    └── indent-string@2.1.0 (repeating@2.0.1)
    debug@2.2.0 node_modules/socket.io/node_modules/socket.io-parser/node_modules/debug
    └── ms@0.7.1
    readable-stream@1.1.14 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/css-rule-stream/node_modules/css-tokenize/node_modules/readable-stream
    ├── string_decoder@0.10.31
    ├── core-util-is@1.0.2
    └── isarray@0.0.1
    redent@1.0.0 node_modules/grunt/node_modules/dateformat/node_modules/meow/node_modules/redent
    ├── strip-indent@1.0.1 (get-stdin@4.0.1)
    └── indent-string@2.1.0 (repeating@2.0.1)
    through2@0.6.5 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/ldjson-stream/node_modules/through2
    ├── xtend@4.0.1
    └── readable-stream@1.0.34 (isarray@0.0.1, string_decoder@0.10.31, inherits@2.0.3, core-util-is@1.0.2)
    source-map@0.4.4 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/source-map
    └── amdefine@1.0.1
    write@0.2.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/file-entry-cache/node_modules/flat-cache/node_modules/write
    └── mkdirp@0.5.1 (minimist@0.0.8)
    postcss-less@0.14.0 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/postcss-less
    readable-stream@2.0.6 node_modules/grunt-eslint/node_modules/eslint/node_modules/concat-stream/node_modules/readable-stream
    ├── process-nextick-args@1.0.7
    ├── util-deprecate@1.0.2
    ├── isarray@1.0.0
    ├── string_decoder@0.10.31
    └── core-util-is@1.0.2
    npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    globby@5.0.0 node_modules/grunt-eslint/node_modules/eslint/node_modules/file-entry-cache/node_modules/flat-cache/node_modules/del/node_modules/globby
    ├── arrify@1.0.1
    ├── object-assign@4.1.0
    ├── array-union@1.0.2 (array-uniq@1.0.3)
    └── glob@7.1.1 (path-is-absolute@1.0.1, inherits@2.0.3, fs.realpath@1.0.0, inflight@1.0.6, once@1.4.0, minimatch@3.0.3)
    async@1.5.2 node_modules/grunt/node_modules/grunt-legacy-util/node_modules/async
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt/node_modules/grunt-cli/node_modules/findup-sync requires glob@'~5.0.0' but will load
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt/node_modules/glob,
    npm WARN unmet dependency which is version 7.0.6
    findup-sync@0.3.0 node_modules/grunt/node_modules/grunt-cli/node_modules/findup-sync
    └── glob@5.0.15 (path-is-absolute@1.0.1, inherits@2.0.3, inflight@1.0.6, once@1.4.0, minimatch@3.0.3)
    configstore@1.4.0 node_modules/snyk/node_modules/configstore
    ├── os-tmpdir@1.0.2
    ├── object-assign@4.1.0
    ├── graceful-fs@4.1.11
    ├── xdg-basedir@2.0.0 (os-homedir@1.0.2)
    ├── write-file-atomic@1.2.0 (imurmurhash@0.1.4, slide@1.1.6)
    ├── osenv@0.1.3 (os-homedir@1.0.2)
    ├── uuid@2.0.3
    └── mkdirp@0.5.1 (minimist@0.0.8)
    through2@0.6.5 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/css-rule-stream/node_modules/through2
    ├── xtend@4.0.1
    └── readable-stream@1.0.34 (inherits@2.0.3, isarray@0.0.1, string_decoder@0.10.31, core-util-is@1.0.2)
    npm WARN engine string-width@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    findup-sync@0.3.0 node_modules/grunt/node_modules/findup-sync
    └── glob@5.0.15 (inherits@2.0.3, once@1.4.0, inflight@1.0.6)
    read-pkg-up@1.0.1 node_modules/grunt/node_modules/dateformat/node_modules/meow/node_modules/read-pkg-up
    ├── find-up@1.1.2 (path-exists@2.1.0, pinkie-promise@2.0.1)
    └── read-pkg@1.1.0 (path-type@1.1.0, load-json-file@1.1.0)
    coffee-script@1.10.0 node_modules/grunt/node_modules/coffee-script
    underscore.string@3.2.3 node_modules/grunt/node_modules/grunt-legacy-util/node_modules/underscore.string
    concat-stream@1.5.0 node_modules/electron-prebuilt/node_modules/extract-zip/node_modules/concat-stream
    ├── inherits@2.0.3
    ├── typedarray@0.0.6
    └── readable-stream@2.0.6 (process-nextick-args@1.0.7, util-deprecate@1.0.2, string_decoder@0.10.31, isarray@1.0.0, core-util-is@1.0.2)
    read-pkg-up@1.0.1 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/meow/node_modules/read-pkg-up
    ├── find-up@1.1.2 (path-exists@2.1.0, pinkie-promise@2.0.1)
    └── read-pkg@1.1.0 (path-type@1.1.0, load-json-file@1.1.0)
    npm WARN engine is-fullwidth-code-point@2.0.0: wanted: {"node":">=4"} (current: {"node":"0.10.29","npm":"1.4.21"})
    esprima@2.7.3 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/cosmiconfig/node_modules/js-yaml/node_modules/esprima
    es6-promise@3.3.1 node_modules/snyk/node_modules/es6-promise
    npm WARN engine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.29","npm":"1.4.21"})
    yargs@3.32.0 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/yargs
    ├── decamelize@1.2.0
    ├── y18n@3.2.1
    ├── camelcase@2.1.1
    ├── window-size@0.1.4
    ├── os-locale@1.4.0 (lcid@1.0.0)
    ├── string-width@1.0.2 (code-point-at@1.1.0, is-fullwidth-code-point@1.0.0, strip-ansi@3.0.1)
    └── cliui@3.2.0 (wrap-ansi@2.0.0, strip-ansi@3.0.1)
    duplexer2@0.0.2 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/duplexer2
    └── readable-stream@1.1.14 (isarray@0.0.1, string_decoder@0.10.31, inherits@2.0.3, core-util-is@1.0.2)
    JSONStream@0.8.4 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/jsonfilter/node_modules/JSONStream
    ├── through@2.3.8
    └── jsonparse@0.0.5
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-weak-map/node_modules/es6-iterator requires d@'^0.1.1' but will load
    npm WARN unmet dependency undefined,
    npm WARN unmet dependency which is version undefined
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-weak-map/node_modules/d
    pretty-bytes@1.0.4 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/nugget/node_modules/pretty-bytes
    ├── get-stdin@4.0.1
    └── meow@3.7.0 (decamelize@1.2.0, trim-newlines@1.0.0, map-obj@1.0.1, object-assign@4.1.0, camelcase-keys@2.1.0, loud-rejection@1.6.0, minimist@1.2.0, redent@1.0.0, normalize-package-data@2.3.5, read-pkg-up@1.0.1)
    inquirer@0.12.0 node_modules/grunt-eslint/node_modules/eslint/node_modules/inquirer
    ├── strip-ansi@3.0.1
    ├── ansi-escapes@1.4.0
    ├── ansi-regex@2.0.0
    ├── chalk@1.1.3 (escape-string-regexp@1.0.5, has-ansi@2.0.0, supports-color@2.0.0, ansi-styles@2.2.1)
    ├── through@2.3.8
    ├── figures@1.7.0 (object-assign@4.1.0, escape-string-regexp@1.0.5)
    ├── cli-cursor@1.0.2 (restore-cursor@1.0.1)
    ├── readline2@1.0.1 (mute-stream@0.0.5, code-point-at@1.1.0, is-fullwidth-code-point@1.0.0)
    ├── string-width@1.0.2 (code-point-at@1.1.0, is-fullwidth-code-point@1.0.0)
    ├── run-async@0.1.0 (once@1.4.0)
    ├── cli-width@2.1.0
    └── rx-lite@3.1.2
    through2@0.2.3 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/nugget/node_modules/progress-stream/node_modules/through2
    ├── xtend@2.1.2 (object-keys@0.4.0)
    └── readable-stream@1.1.14 (isarray@0.0.1, inherits@2.0.3, string_decoder@0.10.31, core-util-is@1.0.2)
    har-validator@2.0.6 node_modules/request/node_modules/har-validator
    ├── pinkie-promise@2.0.1 (pinkie@2.0.4)
    ├── commander@2.9.0 (graceful-readlink@1.0.1)
    ├── chalk@1.1.3 (escape-string-regexp@1.0.5, supports-color@2.0.0, ansi-styles@2.2.1, strip-ansi@3.0.1, has-ansi@2.0.0)
    └── is-my-json-valid@2.15.0 (generate-function@2.0.0, jsonpointer@4.0.0, xtend@4.0.1, generate-object-property@1.2.0)
    through2@0.6.5 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/jsonfilter/node_modules/through2
    ├── xtend@4.0.1
    └── readable-stream@1.0.34 (isarray@0.0.1, inherits@2.0.3, string_decoder@0.10.31, core-util-is@1.0.2)
    acorn@3.3.0 node_modules/grunt-eslint/node_modules/eslint/node_modules/espree/node_modules/acorn-jsx/node_modules/acorn
    fs-extra@0.30.0 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/fs-extra
    ├── path-is-absolute@1.0.1
    ├── klaw@1.3.1
    ├── jsonfile@2.4.0
    ├── graceful-fs@4.1.11
    └── rimraf@2.5.4 (glob@7.1.1)
    hawk@3.1.3 node_modules/request/node_modules/hawk
    ├── cryptiles@2.0.5
    ├── sntp@1.0.9
    ├── boom@2.10.1
    └── hoek@2.16.3
    es6-promise@3.3.1 node_modules/electron-prebuilt/node_modules/electron-download/node_modules/sumchecker/node_modules/es6-promise
    update-notifier@0.5.0 node_modules/snyk/node_modules/update-notifier
    ├── is-npm@1.0.0
    ├── semver-diff@2.1.0
    ├── string-length@1.0.1 (strip-ansi@3.0.1)
    ├── repeating@1.1.3 (is-finite@1.0.2)
    └── latest-version@1.0.1 (package-json@1.2.0)
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt/node_modules/grunt-legacy-log/node_modules/grunt-legacy-log-utils requires lodash@'~4.3.0' but will load
    npm WARN unmet dependency /home/pi/MagicMirror/node_modules/grunt/node_modules/grunt-legacy-log/node_modules/lodash,
    npm WARN unmet dependency which is version 3.10.1
    underscore.string@3.2.3 node_modules/grunt/node_modules/grunt-legacy-log/node_modules/underscore.string
    split2@0.2.1 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/ldjson-stream/node_modules/split2
    └── through2@0.6.5 (xtend@4.0.1, readable-stream@1.0.34)
    through2@0.6.5 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/through2
    ├── xtend@4.0.1
    └── readable-stream@1.0.34 (inherits@2.0.3, isarray@0.0.1, string_decoder@0.10.31, core-util-is@1.0.2)
    esprima@2.7.3 node_modules/grunt-eslint/node_modules/eslint/node_modules/js-yaml/node_modules/esprima
    duplexer2@0.0.2 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/doiuse/node_modules/css-rule-stream/node_modules/duplexer2
    └── readable-stream@1.1.14 (isarray@0.0.1, inherits@2.0.3, string_decoder@0.10.31, core-util-is@1.0.2)
    js-yaml@3.5.5 node_modules/grunt/node_modules/js-yaml
    ├── esprima@2.7.3
    └── argparse@1.0.9 (sprintf-js@1.0.3)
    nconf@0.7.2 node_modules/snyk/node_modules/snyk-config/node_modules/nconf
    ├── ini@1.3.4
    ├── async@0.9.2
    └── yargs@3.15.0 (decamelize@1.2.0, camelcase@1.2.1, window-size@0.1.4, cliui@2.1.0)
    npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    snyk-policy@1.5.2 node_modules/snyk/node_modules/snyk-policy
    ├── lodash.clonedeep@4.5.0
    └── js-yaml@3.7.0 (esprima@2.7.3, argparse@1.0.9)
    lodash@3.10.1 node_modules/grunt/node_modules/grunt-legacy-log/node_modules/lodash
    npm WARN engine co@4.6.0: wanted: {"iojs":">= 1.0.0","node":">= 0.12.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    table@3.8.3 node_modules/grunt-eslint/node_modules/eslint/node_modules/table
    ├── slice-ansi@0.0.4
    ├── ajv-keywords@1.1.1
    ├── string-width@2.0.0 (is-fullwidth-code-point@2.0.0, strip-ansi@3.0.1)
    ├── chalk@1.1.3 (escape-string-regexp@1.0.5, supports-color@2.0.0, ansi-styles@2.2.1, has-ansi@2.0.0, strip-ansi@3.0.1)
    └── ajv@4.9.0 (co@4.6.0)
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-weak-map/node_modules/es6-symbol/node_modules/d
    └── es5-ext@0.10.12 (es6-iterator@2.0.0)
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/es6-symbol/node_modules/d
    └── es5-ext@0.10.12 (es6-iterator@2.0.0)
    lodash@4.3.0 node_modules/grunt/node_modules/grunt-legacy-util/node_modules/lodash
    lodash@4.3.0 node_modules/grunt/node_modules/grunt-legacy-log/node_modules/grunt-legacy-log-utils/node_modules/lodash
    npm WARN engine co@4.6.0: wanted: {"iojs":">= 1.0.0","node":">= 0.12.0"} (current: {"node":"0.10.29","npm":"1.4.21"})
    postcss-reporter@1.4.1 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/stylehacks/node_modules/postcss-reporter
    ├── log-symbols@1.0.2
    ├── chalk@1.1.3 (escape-string-regexp@1.0.5, supports-color@2.0.0, ansi-styles@2.2.1, has-ansi@2.0.0, strip-ansi@3.0.1)
    ├── postcss@5.2.6 (supports-color@3.1.2, js-base64@2.1.9, source-map@0.5.6)
    └── lodash@4.17.2
    table@3.8.3 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/table
    ├── slice-ansi@0.0.4
    ├── ajv-keywords@1.1.1
    └── ajv@4.9.0 (co@4.6.0, json-stable-stringify@1.0.1)
    postcss-reporter@1.4.1 node_modules/grunt-stylelint/node_modules/stylelint/node_modules/colorguard/node_modules/postcss-reporter
    ├── log-symbols@1.0.2
    ├── chalk@1.1.3 (escape-string-regexp@1.0.5, supports-color@2.0.0, ansi-styles@2.2.1, has-ansi@2.0.0, strip-ansi@3.0.1)
    ├── postcss@5.2.6 (supports-color@3.1.2, js-base64@2.1.9, source-map@0.5.6)
    └── lodash@4.17.2
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/event-emitter/node_modules/d
    └── es5-ext@0.10.12 (es6-symbol@3.1.0, es6-iterator@2.0.0)
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/es6-set/node_modules/d
    └── es5-ext@0.10.12 (es6-symbol@3.1.0, es6-iterator@2.0.0)
    snyk-resolve-deps@1.7.0 node_modules/snyk/node_modules/snyk-resolve-deps
    ├── ansicolors@0.3.2
    ├── lru-cache@4.0.1 (pseudomap@1.0.2, yallist@2.0.0)
    ├── minimist@1.2.0
    ├── clite@0.3.0 (lodash.defaults@4.2.0, lodash.mergewith@4.6.0, lodash.defaultsdeep@4.6.0, update-notifier@0.6.3, yargs@4.8.1)
    └── lodash@4.17.2
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-weak-map/node_modules/es6-iterator/node_modules/d
    └── es5-ext@0.10.12 (es6-symbol@3.1.0)
    d@0.1.1 node_modules/grunt-eslint/node_modules/eslint/node_modules/escope/node_modules/es6-map/node_modules/es6-iterator/node_modules/d
    └── es5-ext@0.10.12 (es6-symbol@3.1.0)
    inquirer@1.0.3 node_modules/snyk/node_modules/inquirer
    ├── mute-stream@0.0.6
    ├── through@2.3.8
    ├── cli-width@2.1.0
    ├── run-async@2.2.0 (is-promise@2.1.0)
    ├── figures@1.7.0 (object-assign@4.1.0, escape-string-regexp@1.0.5)
    ├── cli-cursor@1.0.2 (restore-cursor@1.0.1)
    ├── string-width@1.0.2 (code-point-at@1.1.0, is-fullwidth-code-point@1.0.0)
    ├── strip-ansi@3.0.1 (ansi-regex@2.0.0)
    ├── pinkie-promise@2.0.1 (pinkie@2.0.4)
    ├── rx@4.1.0
    └── lodash@4.17.2
    pi@raspberrypi:~/MagicMirror $ 
    pi@raspberrypi:~/MagicMirror $ 
    pi@raspberrypi:~/MagicMirror $ npm install && npm start
    |
    > magicmirror@2.0.0 prepublish /home/pi/MagicMirror
    > npm run snyk-protect
    
    
    > magicmirror@2.0.0 snyk-protect /home/pi/MagicMirror
    > snyk protect
    
    Successfully applied Snyk patches
    npm ERR! peerinvalid The package grunt does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer grunt-eslint@19.0.0 wants grunt@>=0.4.0
    npm ERR! peerinvalid Peer grunt-yamllint@0.2.0 wants grunt@~0.4.0
    
    npm ERR! System Linux 4.4.21-v7+
    npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21
    npm ERR! code EPEERINVALID
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    pi@raspberrypi:~/MagicMirror $


  • @Jeff as the error tells you have to upgrade first node in order to update npm, you’re running node 0.10 there is already version 7.x



  • @strawberry-3.141

    Can you tell me the right code, please?
    I could try some versions, but I don’t want mess everything up.

    I tied:

    pi@raspberrypi:~ $ sudo npm cache clean -f
    npm WARN npm npm does not support Node.js v0.10.29
    npm WARN npm You should probably upgrade to a newer version of node as we
    npm WARN npm can't make any promises that npm will work with this version.
    npm WARN npm You can find the latest version at https://nodejs.org/
    npm WARN using --force I sure hope you know what you are doing.
    pi@raspberrypi:~ $


  • Oh snap, @strawberry-3-141 is right. Of course, I meant, that your nide version is too old. Did you try to update/install node via apt? Try apt-get update && apt-get upgrade or apt-get install nodejs and see, if it helps.

    If it doesn’t work, follow the instructions here, to install a recent version of node: https://nodejs.org/en/download/package-manager/#debian-and-ubuntu-based-linux-distributions



  • great! That worked out.
    Thanks alot

    I was trying it that way

    wget https://nodejs.org/dist/v4.0.0/node-v4.0.0-linux-armv7l.tar.gz 
    tar -xvf node-v4.0.0-linux-armv7l.tar.gz 
    cd node-v4.0.0-linux-armv7l
    

    Just for the latest version…

    But okay…

    Now I need to install npm as you said in your first post?

    Edit:
    I think it works now. At least the screen pops up.
    Just the weather forecast isn’t working right now.

    Can you have look at the code if everythin is correct so far?

    pi@raspberrypi:~/MagicMirror $ npm install && npm start
    npm WARN prepublish-on-install As of npm@5, `prepublish` scripts will run only for `npm publish`.
    npm WARN prepublish-on-install (In npm@4 and previous versions, it also runs for `npm install`.)
    npm WARN prepublish-on-install See the deprecation note in `npm help scripts` for more information.
    
    > magicmirror@2.0.0 prepublish /home/pi/MagicMirror
    > npm run snyk-protect
    
    
    > magicmirror@2.0.0 snyk-protect /home/pi/MagicMirror
    > snyk protect
    
    Successfully applied Snyk patches
    npm WARN grunt-yamllint@0.2.0 requires a peer of grunt@~0.4.0 but none was installed.
    
    > magicmirror@2.0.0 start /home/pi/MagicMirror
    > electron js/electron.js
    
    
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    No helper found for module: clock.
    Initializing new module helper ...
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper ...
    All module helpers loaded.
    Starting server op port 8080 ... 
    Server started ...
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started ...
    Launching application.
    Create new calendar fetcher for url: http://www.calendarlabs.com/templates/ical/US-Holidays.ics - Interval: 300000
    Create new news fetcher for url: http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml - Interval: 300000
    pi@raspberrypi:~/MagicMirror $ 
    pi@raspberrypi:~/MagicMirror $ ^C
    pi@raspberrypi:~/MagicMirror $ sudo npm install && npm start
    npm WARN prepublish-on-install As of npm@5, `prepublish` scripts will run only for `npm publish`.
    npm WARN prepublish-on-install (In npm@4 and previous versions, it also runs for `npm install`.)
    npm WARN prepublish-on-install See the deprecation note in `npm help scripts` for more information.
    npm WARN lifecycle magicmirror@2.0.0~prepublish: cannot run in wd %s %s (wd=%s) magicmirror@2.0.0 npm run snyk-protect /home/pi/MagicMirror
    npm WARN grunt-yamllint@0.2.0 requires a peer of grunt@~0.4.0 but none was installed.
    
    > magicmirror@2.0.0 start /home/pi/MagicMirror
    > electron js/electron.js
    
    Loading config ...
    Loading module helpers ...
    No helper found for module: alert.
    No helper found for module: clock.
    Initializing new module helper ...
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper ...
    All module helpers loaded.
    Starting server op port 8080 ... 
    Server started ...
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Sockets connected & modules started ...
    Launching application.
    Create new calendar fetcher for url: http://www.calendarlabs.com/templates/ical/US-Holidays.ics - Interval: 300000
    Create new news fetcher for url: http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml - Interval: 300000


  • Today I reinstalled my Pi.
    This time with Noob style, but with the image itself.

    After that, the automatic MagicMirror installation worked finde. Everything was updated correctly. Yesterday it didn’t work at all.
    Also I had the problem that google clalenders would not show up in the Magic Mirror.
    Today everything works fine.

    Maybe there is a problem with Noob installation?!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.