Black Screen on Localhost...



  • Hi…i have installed node and the MM2 to test in a Pc before starting with Pi and entering to localhost:8080 the screen is black…no text…no nothing :(
    The config.js is already in 8080 too what could be happening? Thanks



  • @Leotrap Usually a black screen means that there is an error in the config.js file. First, I would start the mirror in dev mode via npm start dev. It should show you the browser console so you can see if there are any error messages.



  • Thanks @bhepler this is what I got 0_1480555648940_upload-426cb398-ef76-48cd-ae45-6ecd5b1b7aec



  • @Leotrap Hrm. That’s really weird. It’s like it wasn’t expecting the very first character of the index.html file. Let’s try without the dev tag. First, remove the debug log at C:\Users\usario\Downloads\MagicMirror-master\MagicMirror-Master\npm-debug.log if it exists. Run the mirror normally with npm start from within the MagicMirror-Master\MagicMirror-Master folder. If you still get a black screen, stop your npm process and then see if that log file has been recreated.

    If it has, copy it in here using the markdown features and we’ll take a look at it.



  • Hi @bhepler I did what you told and exactly the same is happening but withouts the DEV after the index.html. I Attach capture and the debug created… Thanks man
    0_1480623461551_dev.jpg [0_1480623474461_npm-debug.log](Uploading 100%)



  • This post is deleted!


  • 0 info it worked if it ends with ok
    1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
    1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
    1 verbose cli ‘start’ ]
    2 info using npm@3.10.8
    3 info using node@v6.9.1
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.0.0~prestart: magicmirror@2.0.0
    6 silly lifecycle magicmirror@2.0.0~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.0.0~start: magicmirror@2.0.0
    8 verbose lifecycle magicmirror@2.0.0~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.0.0~start: PATH: C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin;C:\Users\usuario\Downloads\MagicMirror-master\MagicMirror-master\node_modules.bin;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Common Files\Intel\Shared Libraries\redist\intel64\compiler;C:\Program Files (x86)\HP SimplePass;C:\Program Files (x86)\Intel\iCLS Client;C:\Program Files\Intel\iCLS Client;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x64;C:\Program Files\Intel\Intel® Management Engine Components\DAL;C:\Program Files\Intel\Intel® Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel® Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel® Management Engine Components\IPT;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon;C:\Program Files (x86)\QuickTime\QTSystem;C:\Program Files\Common Files\Autodesk Shared;C:\Program Files (x86)\Autodesk\Backburner;C:\Program Files\OpenNI\Bin64;C:\Program Files\PrimeSense\NITE\bin64;C:\Program Files (x86)\Skype\Phone;C:\Program Files\nodejs;C:\Users\usuario\AppData\Local\Microsoft\WindowsApps;C:\Users\usuario\AppData\Roaming\npm
    10 verbose lifecycle magicmirror@2.0.0~start: CWD: C:\Users\usuario\Downloads\MagicMirror-master\MagicMirror-master
    11 silly lifecycle magicmirror@2.0.0~start: Args: [ ‘/d /s /c’, ‘node index.html’ ]
    12 silly lifecycle magicmirror@2.0.0~start: Returned: code: 1 signal: null
    13 info lifecycle magicmirror@2.0.0~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.0.0 start: node index.html
    14 verbose stack Exit status 1
    14 verbose stack at EventEmitter. (C:\Program Files\nodejs\node_modules\npm\lib\utils\lifecycle.js:255:16)
    14 verbose stack at emitTwo (events.js:106:13)
    14 verbose stack at EventEmitter.emit (events.js:191:7)
    14 verbose stack at ChildProcess. (C:\Program Files\nodejs\node_modules\npm\lib\utils\spawn.js:40:14)
    14 verbose stack at emitTwo (events.js:106:13)
    14 verbose stack at ChildProcess.emit (events.js:191:7)
    14 verbose stack at maybeClose (internal/child_process.js:877:16)
    14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
    15 verbose pkgid magicmirror@2.0.0
    16 verbose cwd C:\Users\usuario\Downloads\MagicMirror-master\MagicMirror-master
    17 error Windows_NT 10.0.14393
    18 error argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” "start"
    19 error node v6.9.1
    20 error npm v3.10.8
    21 error code ELIFECYCLE
    22 error magicmirror@2.0.0 start: node index.html
    22 error Exit status 1
    23 error Failed at the magicmirror@2.0.0 start script ‘node index.html’.
    23 error Make sure you have the latest version of node.js and npm installed.
    23 error If you do, this is most likely a problem with the magicmirror package,
    23 error not with npm itself.
    23 error Tell the author that this fails on your system:
    23 error node index.html
    23 error You can get information on how to open an issue for this project with:
    23 error npm bugs magicmirror
    23 error Or if that isn’t available, you can get their info via:
    23 error npm owner ls magicmirror
    23 error There is likely additional logging output above.
    24 verbose exit [ 1, true ]


  • Moderator

    What happens, if you run node serveronly instead?



  • Might be a silly question, but did you run npm install on the mirror root folder to install dependencies? And you made sure node.js is installed on your machine before you got started?



  • Hi guys! From the Cmd I have this… (Attached Image.) The root is fine @jeremytripp and @yawns the problem persist from node trying the nose serveronly too :( In the last inage youl’ss that if i enter to localhost everything will be fine… the dark screen appears…that’s goo… but the probles is that modules are not showned…

    2_1480625016576_npm-express.jpg 1_1480625016576_3.jpg 0_1480625016576_2.jpg


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.