MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

grafana module for bar graphs display.

  • Hello people! alright ?

    There is a graphical module on the site, but the author does not access for more than 2 years.

    I would like to use a module so that I can display the bar graph horizontally.

    It is a wonderful tool. Someone create or maintain the existing module.

  • Project Sponsor Module Developer

    Well that’s how it goes sometimes. People create modules that they give away for free so they can’t possibly give free support forever. They get busy in life and they move on…

    You can either go to the Github repository where the module is and ask questions or post issues


    You can do a ‘fork’ and maintain and/or improve it.

    I don’t think asking someone else to do it is going to get you any results. Not trying to be rude here but this is a project where the user is supposed to take an active part in and learn…
    Now if you try this and run into an issue I’m sure one of us would be glad to help you 🙂

  • I understood what you wrote. I wasn’t upset.

    But unfortunately, my knowledge of programming is limited. I always help, in the things I master. I made the request in the forum area where it says it is to request modules. So I was calm.

    But it’s alright! Thank you, I will look for another solution to integrate my HA with MM.

  • Module Developer


    looking at the module, it is just an iFrame that displays a grafana graph. So there is not much anyone on here could do. I don’t know anything about graphana, but from what I’ve seen, it seems like graphana is capable of doing “horizontal graphs” (meaning bars vertically stacked and growing horizontally?).

    Seems like you’d have to look for help in the grafana community. As I said, it seems like the module here just shows whatever you have in grafana.

    Do you have a grafana ready? Or an example of an image what you have and what it should look like?


  • @doubleT

    I have the graphics ready on the graphana and everything is working.

    In fact, I am in a tireless quest to display my HA data in MM. And I found the module HA> graphana> MM. But it is abandoned.

  • Module Developer

    Ok, I cloned the module, set up a grafana and tried it out.

    The console error shows: Refused to display '' in a frame because it set 'X-Frame-Options' to 'deny'.

    Searching for that on Google brought me to the Grafana website:

    Embedding Grafana

    If you’re embedding Grafana in a frame, iframe, embed or object on a different website it will no longer work due to a new setting that per default instructs the browser to not allow Grafana to be embedded.

    There are two topics on that:,

    Without any further investigation it seems like there are some settings that need to be done when you’re hosting grafana? So maybe it’s not possible to get to these settings on the free hosted versions?

    There are two other issues:
    If using the free hosted version there’s something about an API key. That might be an issue as well?
    And the module config is not asking for the entire grafana URL but wants several parts of the URL, but the actual grafana URL seems to be different to what the module is making out of these parts.

    Sorry, at the moment I can’t look any further into this, maybe someone else is interested in grafana and comes up with a solution.


  • @doubleT Im on the same boat;
    i can display the grafana playlist on every single device on same subnet (TV, mobile, PC, laptop) except the mirror (hosted on a pi). so i guess there’s something with electron cause it works on other devices as i said…
    here part of grafana.ini config file involving security.


    here dev console logs

    Load denied by X-Frame-Options: http://192.168.x.x:3000/playlists/play/1?kiosk does not permit framing.

    tried to show the playlist with MMM-iFrame, MMM-SmartWebdisplay & MMM-Widget with same results.
    btw: grafana hosted on another pi inside a docker container…just leave it here with hope some of the expets here can throw some suggestion.

  • maybe that will help you.


  • @Piranha1605 Thanks tried that already, it trows:
    ‘The play method is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.’

Log in to reply