MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Help please. Module doesn't show up



  • I’m learning to build a Magic Mirror as a distraction from the quarantine. Other modules have worked, but this one just doesn’t show up. Can one of you tell me what I’ve done wrong .

    Screen Shot 2020-05-25 at 5.06.53 PM.png


  • Project Sponsor Module Developer

    @blacter

    You’re missing a } bracket at the end. Remove the comma that I see below the label line (on the bracket) go to the next line and add this bracket ]. Notice the comma now is required.

      {
         module: 'MMM-SingleStock',
         position: 'top_right',
         config: {
           stockSymbol: 'GOOG',
           apiToken: 'YOUR API TOKEN',  // Unique, private API key obtained from https://iexcloud.io/console/tokens
           updateInterval: 3600000, // 1 hour in milliseconds
           showChange: true,        // false | true
           label: 'symbol'          // 'symbol' | 'companyName' | 'none' | any string
         }
       },
    

  • Project Sponsor

    @blacter - Okay, a couple things.

    First, it’s best to use the markdown features of the board when posting code, rather than screenshots.

    Second, you should obfuscate or hide your API keys, lest someone “borrow” them for their own use.

    Third, the line obtained from https://iexcloud.io/console/tokens appears to be on its own line without a comment prefix (the // characters) so it is being evaluated by the interpreter. And because it’s a comment and not a setting, it’s probably barfing on that line.

    Fourth, the code you quoted is missing a closing } symbol. You have one opened for the config: { line and another open for the { module: 'MMM-SingleStock', portion… but you only have one closing }.

    I hope that gets you on your way.

    Edited to add: Dammit, @Mykle1 beat me to it.


  • Project Sponsor Module Developer

    @bhepler said in Help please. Module doesn’t show up:

    Edited to add: Dammit, @Mykle1 beat me to it.

    👍


Log in to reply