MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Portrait Mode



  • Hi there guys

    Can anyone help with instructions on how to rotate screen from Landscape, to Portrait?

    Ive had help on this within another unrelated post here, but that fix will not work… by going into Terminal > Boot> Config.txt, and entering - display_rotate=1.

    Version and OS — 2.11.0… Raspbian GNU/Linux 9.11 { Stretch }
    RPi3

    Thanks



  • @johnnyboy for others, what pi and OS version please



  • See this thread:
    https://forum.magicmirror.builders/topic/9730/led-monitor-vertical-setup-how?_=1591998940597

    In your case I would try

    display_hdmi_rotate=1


  • Project Sponsor

    @johnnyboy - In the latest version of Raspbian Buster, you can rotate it through the UI. But you have to do a full OS update so as to include the latest version of the desktop.

    On the pi, open a terminal window (ctrl+t) and update everything: sudo apt update && sudo apt upgrade -y

    That step will take a while to complete. Depending on your model of Pi, expect 30 minutes or so. It will require a reboot at the end, so reboot your Pi.

    Once the Pi is back up, you’ll be at the desktop. If you’ve already installed Magic Mirror, you’ll want to stop it by opening a terminal window and entering pm2 stop all. Go to the Raspberry button follow Raspberry -> Preferences -> Screen Configuration. The configuration dialog will appear. Follow the menu like so: Configure -> Screens -> HDMI1 -> Orientation and make your selection to rotate the screen. It will enable the green check mark which will apply your selection.

    Select whichever orientation makes sense for you. Just so you know, the descriptions describe the bottom of the monitor. So the “left” entry puts the bottom of the monitor on the left in portrait mode.


  • Module Developer



  • @bhepler said in Portrait Mode:

    @johnnyboy - In the latest version of Raspbian Buster, you can rotate it through the UI. But you have to do a full OS update so as to include the latest version of the desktop.

    Okay, did a complete erase of SD Card that had Strech OS on it… flashed it with Buster, and installed Sam`s Script and installed MM… all went well!

    On the pi, open a terminal window (ctrl+t) and update everything: sudo apt update && sudo apt upgrade -y

    Did that… Reported nothing to update

    That step will take a while to complete. Depending on your model of Pi, expect 30 minutes or so. It will require a reboot at the end, so reboot your Pi.

    Once the Pi is back up, you’ll be at the desktop. If you’ve already installed Magic Mirror, you’ll want to stop it by opening a terminal window and entering pm2 stop all. Go to the Raspberry button follow Raspberry -> Preferences -> Screen Configuration. The configuration dialog will appear. Follow the menu like so: Configure -> Screens -> HDMI1 -> Orientation and make your selection to rotate the screen. It will enable the green check mark which will apply your selection.

    Not sure why, but my preferences show exactly the same options as Strech did… there is no Screen Configuration.

    What i have in Preferences is - Add/Remove Software - Appearance Settings - Mouse and keyboard - Main Menu Editor - Raspberry Pi Configuration - Recommended Software… looked into all of them and cannot see ’ Screen Configuration’

    Select whichever orientation makes sense for you. Just so you know, the descriptions describe the bottom of the monitor. So the “left” entry puts the bottom of the monitor on the left in portrait mode.



  • @BKeyport said in Portrait Mode:

    https://pimylifeup.com/raspberry-pi-rotate-screen/

    Thanks… this done the trick…

    display_hdmi_rotate=1



  • @evroom said in Portrait Mode:

    See this thread:
    https://forum.magicmirror.builders/topic/9730/led-monitor-vertical-setup-how?_=1591998940597

    In your case I would try

    display_hdmi_rotate=1

    Wish I tried this first… but wanted to erase SD Card and put Buster on, so tried raspberry button > preferences… which hand no option for screen orientation.

    This indeed was what rotated screen to Portrait.


  • Project Sponsor

    @johnnyboy said in Portrait Mode:

    Not sure why, but my preferences show exactly the same options as Strech did… there is no Screen Configuration.

    Yeah, that’s a puzzler. Let me do some research and see if I can’t figure out what’s going on. It’s possible that I forgot a step. How embarassing.


Log in to reply