Sonos Module



  • Hi Guys.

    Hope that some of you can help me.
    I have problems with my sonos module,
    On the mirror it`s only saying loading music.
    On my pi i get
    Sonos Update
    Failure Error: Connect Econnrefused 192.168.0.79

    I can access 192.168.0.79:5005 and change song and change volym and so on.
    Any ide why i can’t get any information on my mirror ???

    Kind regards

    Jonas


  • Module Developer

    Hi @Atreo do you have the http-sonos-api installed on your mirror or on another device?
    I had problems before I ran on a raspberry Pi when I ran the mirror in Server mode. Don’t know why though. :)



  • Hi @Snille Thx for the reply.

    Yes i have sonos-http-api installed on my mirror,
    This is making me crazy, i like the ide to have the information on the mirror.
    Banging my head against the wall…



  • I have the Sonos mod running on my Mirror. I get the same thing when I run more than one speaker as a group. If I run each speaker as separate it will load each speaker fine. I haven’t bothered looking into it much as I rarely use the speakers in group mode…



  • Thx for the info @Wedee, I only have one and i am stuck… = /
    Any one have any tips ?


  • Module Developer

    @Atreo Do you get the “zones” up if you do: http://192.168.0.79:5005/zones ?
    You should get a list of all the zones and stuff. :)



  • @Snille Yes i can my kitchen zone and i hole lot information what the sonos is playing.


  • Module Developer

    @Atreo Hmm… Then it should be all good. Can you post your “MMM-Sonos” part of the config?


  • Module Developer

    @Atreo This is my “MMM-Sonos” config part…

    		{
    			module: "MMM-Sonos",
    			header: "Spelas på SONOS",
    			position: "top_center",
    			classes: "",
    			config: {
    				// The API is not om my RPi. It's on another server...
    				apiBase: "http://ip-of-the-api",
    				apiPort: 5005,
    				showAlbumArt: true,
    				showRoomName: true,
    				showPausedZone: false,
    				showStoppedRoom: false,
    				preRoomText: 'Rum: ',
    				preArtistText: 'Artist: ',
    				preTrackText: 'Spår: ',
    				preTypeText: 'Källa: ',
    				animationSpeed: 1000,
    				apiEndpoint: "zones",
    				exclude: ["Living-Room-SUB"]
    			}
    		},
    


  • @Snille Thx. I will check your setting vs my.

    Trevligt att du har det på svenska = )
    Tack återkommer strax


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.