Problem with ip whitelist



  • I picked up a new SD card today, and did a clean install from scratch on my wife’s mirror. Now all of the sudden I am having problems connecting via port 8080 from any other device. I downloaded all of the modules that were on the old SD and literally copy/pasted the config.js so I’m not sure what got broken in the transition. Here is the whitelist rule:

    var config = {
    	port: 8080,
    	ipWhitelist: ["127.0.0.1", "::ffff:192.168.1.1/120", "::ffff:127.0.0.1", "::1"],
    
    	language: 'en',
    	timeFormat: 24,
    	units: 'imperial',
    


  • @ottobot

    Here’s mine. It works, if you care to give it a try

    var config = {
    	port: 8080,
    	ipWhitelist: ["::fff:0.0.0.0/1", "::fff:128.0.0.0/2", "::fff:192.0.0.0/3", 
    			"::fff:224.0.0.0/4", "127.0.0.1", "::ffff:127.0.0.1", "::1"], 
    


  • Still no dice. It’s weird. Literally nothing changed config wise. Just the SD card. The mirror works, and I can get to it via ssh. For some reason though I can’t get to it in a browser from any other computer on my network.



  • It may have been setup as a new device on your network with a different IP address due to the clean install.

    For example, if you were previously previewing the mirror at 192.168.1.2:8080, it could have been reassigned to something like 192.168.1.7:8080.

    Check your router LAN settings to see what IP address has been assigned to it.


  • Module Developer

    I’ve noticed that if there is an error in the config.js, I’ll get the an access denied error.

    Have you checked the logs? Try connecting using SSH and run something like pm2 restart mm | pm2 logs mm and watch the log carefully. If it really is an access error, the log will tell you.



  • @leadfarmer router has the address reserved



  • @Cato I’m running it on a zero, so no pm2 sadly. I’m going to try another fresh install on another SD card on another zero when I get home from work today and see if I can reproduce it or if it’s just a weird hiccup.


  • Core Contributors

    If you have troubles with range, IP, etc… Can set ipWhitelist: [] to allow all IP addresses.

    Warning, this enables from everywhere (on your net) have access.


  • Module Developer

    @roramirez Cool, didn’t know that! :)



  • @roramirez Nice! Worked perfect. Thank you.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.