MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

MagicMirror on Pi Zero W


  • Module Developer

    @Hawking Thanks for all your help and comments, I’ve managed to get it up and running now!

    Now I just need to get the whitelist sorted 😬



  • @Mitchfarino said in MagicMirror on Pi Zero W:

    @Hawking Thanks for all your help and comments, I’ve managed to get it up and running now!

    No problem.

    @Mitchfarino said in MagicMirror on Pi Zero W:

    Now I just need to get the whitelist sorted 😬

    This worked fine for me, I just added the IP of my regular PC (e.g 192.168.2.185) to the list in the config file so that it looked like

    ipWhitelist: ["192.168.2.185", "127.0.0.1", "::ffff:127.0.0.1", "::1"],
    

    If I then typed the ip:port (the port is also defined in the MM config, default is 8080) of my raspi (e.g.

    http://192.168.2.170:8080/
    

    ) in the browser bar of my regular PC I could see the page also on my regular PC (took 1-2 seconds to load).
    If this does not work for you, just open a new thread and provide details.



  • BLANK SCREEN, NO CLOCK/CALENDAR/MOMENTS solved and simplified from other topics and posts:

    After you follow the instructions in the first post to #23 then jump to here:

    24 cd ~/MagicMirror/vendor
    25 npm install
    26 sudo reboot

    I’m not a linux expert, but I built this a few weeks back before the latest version of MM and it worked flawlessly. There should be a hook in the original package.json that kicks it into the vendor directory and runs “npm install” there but it doesn’t happen now (5/3/2017).

    Also, for those of you who do not have a monitor, after you SSH into your Rpi Zero W:
    sudo raspi-config
    5 interfacing options
    P3 VNC
    YES you want to enable the VNC server
    reboot when it asks.

    Use VNC Viewer or whatever, connect to your rpi using either ip address or if you set it up in your DHCP table with a :0 (zero) to see your screen or :1 to have a desktop.

    CaptnJB



  • This post is deleted!


  • @Iseknutz said in MagicMirror on Pi Zero W:

    I installed the image from https://forum.magicmirror.builders/topic/1183/how-i-got-my-magic-mirror-working-on-a-raspberry-pi-0-zero/84 , updated the System to use the onboard wifi and this works for me.

    @Iseknutz
    At least I can get this method up and running on my RPI0w, but what’s the trick to updating the system to use the onboard wifi? I’ve created the wpa_supplicant.conf and I’ve even jacked with the etc/network/interfaces - but no luck getting it to connect to the network.
    Thx



  • @kylelmartin can you post or pm your WPA_supplicant.conf file? Please remove your passwords and maybe change your wifi name if that makes you feel better.

    How are you updating your wpa-supplicant through a terminal or by copying it onto your card? Windows or Mac?
    CaptnJB



  • @CaptnJB
    here is the wpa_supplicant.conf file - or at least the latest rendition of it.

    country=US
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    
    network={
        ssid="KLM-Guest"
        key_mgmt=NONE
        priority=1
        id_str="guest"
    }
    
    network={
        ssid="mywebsite.com"
        psk="oldasspw"
        priority=2
        id_str="klm"
    }
    
    

    My regular old wifi network name has a “.” in the name and I thought that might cause some problems. So, I set up a second guest wifi network so this device wouldn’t need a password.



  • @kylelmartin, I apologize for the delay just landed in Madrid. For starters I would take out the id lines. Keep it simple. Try this.

    country=US
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    
    network={
        ssid="KLM-Guest"
        psk=""
        priority=1
    }
    
    network={
        ssid="KLM"
        psk="oldasspw"
        priority=2
    }
    

    Also, mywebsite.com should be be your router ssid. If you have it set to that “mywebsite.com” in the file you gave it is most likely “KLM”.

    Why would you want the guest network to have priority?

    CaptnJB



  • @kylelmartin after the Update to the actual OS, the Onboard-WiFi from my raspi0 was automatically enabled. Did you use the Desktop or console?



  • @Iseknutz I use ssh and nano. I also am a Mac user.

    I’m glad it’s working

    CaptnJB