Black Screen after Launching application.



  • When i run the application it starts and a Black Screen comes and nothing is displayed… i tried various ways but still does not show anything

    every command is working fine, logs start stop but it does not display anything

    Please help

    pi@raspberrypi:~/MagicMirror $ npm start

    magicmirror@2.1.1 start /home/pi/MagicMirror
    sh run-start.sh

    Starting MagicMirror: v2.1.1
    Loading config …
    Loading module helpers …
    No helper found for module: aiclient.
    No helper found for module: aiclientdebugger.
    All module helpers loaded.
    Starting server on port 8080 …
    Starting server op port 8080 …
    Server started …
    Sockets connected & modules started …
    Launching application.



  • Far as I can tell, there is a black screen when you made a mistake in the config.js file or if you made a mistake in the code of module.
    Did you wrote the module you want to use yourself ?


  • Module Developer

    @undergroundauth

    Try starting with dev tools and click console once it has started. Are you getting any errors reported there?

    pi@raspberrypi:~/MagicMirror $ npm start dev



  • application runs fine on pi@raspberrypi:~/MagicMirror $ npm start dev but again black screen nothing can be seen, i checked the logs they also shows no error, i have only used the default modules



  • @romain - i just did the git clone of the repository and no new addition done to any modules


  • Module Developer

    @undergroundauth said in Black Screen after Launching application.:

    i just did the git clone of the repository and no new addition done to any modules

    a git clone of the repo would only try to download the repo again. A git pull would try to update. Make sure your node is up to date and try again if it updates. I assume you did an npm install in the MagicMirror directory, as per the installation instructions.

    Did you do the automatic installation?
    The manual installation?
    Update from 2.1.0?



  • @Mykle1 - I did the same as you said, here is the log of the dev environment it appers to be the problem with aiclient//aiclient.js

    Please help

    main.js:406 Initializing MagicMirror.
    translator.js:182 Loading core translation file: translations/en.json
    translator.js:204 Loading core translation fallback file: translations/en.json
    loader.js:182 Load script: modules/aiclient//aiclient.js
    aiclient.js Failed to load resource: the server responded with a status of 404 (Not Found)
    loader.js:190 Error on loading script: modules/aiclient//aiclient.js
    script.onerror @ loader.js:190
    loader.js:182 Load script: modules/aiclientdebugger//aiclientdebugger.js
    aiclientdebugger.js Failed to load resource: the server responded with a status of 404 (Not Found)
    loader.js:190 Error on loading script: modules/aiclientdebugger//aiclientdebugger.js
    script.onerror @ loader.js:190
    loader.js:197 Load stylesheet: css/custom.css
    main.js:424 All modules started!



  • @undergroundauth This is weird, you said you did not add module and yet, your log talk about “modules/aiclient” wich isn’t a default module . In a fresh cloned repository, your modules folder should only have a “default” folder, a “node_modules” folder and a “Readme.md” file in it.
    your error talk about a “modules/aiclient” so it’s clear that you have another folder named “aiclient” in it. And If there is an error on it, it’s also mean the magic mirror try to call it which mean you add a section on the “config/config.js” file in the magic mirror repository.
    So this module must have an error in it that messed up the display.
    do something like renaming the current config file and reset the default value on a new one.
    the following command should do the trick

    mv ~/MagicMirror/config/config.js ~/MagicMirror/config/old_config.js.save
    cp ~/MagicMirror/config.js.sample ~/MagicMirror/config.js
    

    If you didn’t mess with the config.js.sample it should reset your config.js to the default configuration.
    Try to run the magic mirror next and tell us if something appear on the mirror.



  • Hi,
    Even I have the same black screen problem. I have not added any other modules. Just have renamed the config.js.sample to config.js
    The application launches with a black screen.



  • @dhirajv12
    In the terminal it says
    No helper found for module: clock
    no helper found for module: complements


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.